LensCal

このプログラムは机上でレンズを設計し収差等を評価するためのものを目指しています。

現在できること
・焦点距離の計算、焦点距離に合わせたデータの修正
・レンズ断面の表示、印刷
・３次収差係数の計算
・球面収差、非点収差、歪曲収差曲線の計算、印刷
・スポットダイヤグラムの計算、印刷
・波面収差、波動光学的像面図、OTFの計算
・ベンディングによる収差変化
・収差が最小になる、レンズ曲率等のデータ最適化（自動設計とも言うが、そんな大それたことはできない）
等です。


インストール

LensCalのインストールは、ダウンロードした LensCb??.lzh ファイルを任意のフォルダ上に解凍して下さい。LensCal.exe ファイル等が作成され、さらにデータを入れる Lens フォルダが生成されます。
このヘルプファイルも同一のフォルダ上にコピーして下さい。

元の圧縮ファイルは不要なので消去できます。

アンインストールには、そのままファイルを消去して下さい。新規フォルダにインストールした場合には、フォルダごと消去すれば OK です。


起動

プログラムを開始するにはエクスプローラ等から LensCal.exe の入ったフォルダを選択し LensCal.exe をダブルクリックして下さい。
ショートカットアイコン等を作成しておくと便利です。


使い方

一からレンズデータを作成する場合は、使い方の例その１を見て下さい。

既存データを読み込む場合には、｢ファイル｣－｢open｣又は左から２つ目のアイコンのクリックでファイル読み込みのダイヤログを 起動し、希望のファイルを選択します。

収差曲線の表示等は、｢ツール｣の中にあります。
・３次収差係数の表示、
・縦、横球面収差図、非点収差、歪曲収差図
・スポットダイヤグラム、
・波面収差図、波動光学的像面図
・OTF
・レンズ断面の表示
ができます。

・焦点距離
を選択すると焦点距離が計算され、また希望の焦点距離に変更することができます。

・自動修正
によって、収差極小になるようにデータの最適化ができます。


使い方の例　その１

口径100mm、F10のアクロマート屈折望遠鏡レンズを設計してみましょう。

  まずプログラムを起動します。エクスプローラ等から LensCal.exe のアイコンをダブルクリックすればソフトが立ち上がります。エラーが表示されるときには、同一フォルダ内に lensdata.ldt 及び sumita.txt があるかどうか確認しましょう。

  はじめに、有効径のセルが色が変わっていますので、｢100｣ と入れます。これはあとからでもできます。
次にカーソルを下に移動させると No1 の新たな行が出てきます。再び有効径に ｢100｣ と入れます（入れなくてもかまいません）。
次に硝種の ｢Air｣ の下のセルをダブルクリックするとダイヤログが出てくるので、｢Sumita｣ のボタンをクリックします。
  ガラスの一覧表の中から ｢K-BK7｣ を選び（左のボタン色以外のところをクリック）、 ｢Select｣ ボタンをクリックします。
  本来ならハーティングの式を用いて曲率等を決めるべきなのですが、ここは簡単に適当に数字を入れてあとで修正しましょう。 ｢曲率半径｣ のセルには ｢300｣ 、｢距離｣ のセルには ｢15｣ とでも入れておきましょう。
  再びカーソルを下に移動させ、No2 の硝種のセルをダブルクリックして ｢Air｣ を選択、｢曲率半径｣ は ｢-200｣、｢距離｣ は ｢0.5｣ を入れてみます。

  No.2 の行の下の空欄をクリックしてみましょう。 No3 の行という行が現れます。
今度は、No3の行にカーソルを移したあとに ｢データ｣－｢glass｣－｢Sumita｣ を選んでみましょう。 硝種のセルのダブルクリックのときと同様にガラスの一覧表が出てきます。
上の黄色の帯の中で ｢GNAME｣ のところをクリックすると、ガラスが ABC 順にソートされます。すぐ下の F のところにある ｢F2｣ を選択しましょう。
  ｢曲率半径｣ は ｢-200｣ 、｢距離｣ は ｢8｣ としておきます。
  No4の行には、ガラスは ｢Air｣ を選択、｢曲率半径｣ は ｢0｣ （平面・入れなくてもかまいません）とします。

  ここで念のためデータをセーブしておきましょう。フロッピーのアイコンをクリックするとセーブダイヤログが立ち上がりますので、適当に名前をつけましょう。拡張子には ｢.ldt｣ を用いると便利です。

その２へ


使い方の例　その２

  次に ｢ツール｣－｢焦点距離｣ を選んでみましょう。現在の焦点距離が出てきますが、希望のものとはかなりずれています。
データを変更するわけですが、その前にレンズ厚みが変わらないよ うに、いったん焦点距離ダイヤログを ｢Cancel｣ で閉じたあとに、No. １、２，３の行（BK7、Air、F2 の行）の ｢LFix｣ のセルをダブルクリックして、｢ｘ｣ マークを付けておきましょう。
  もう一度焦点距離ダイヤログを ｢ツール｣－｢焦点距離｣ で出し、[Tab] キーを押してボックスにフォーカスをもっていき、内容を消去して、目標の ｢1000｣mm を入力し、｢OK｣ ボタンを押しましょう。焦点距離が 1000mm になるように、曲率半径が変わります。
  もし間違って先に ｢Cancel｣ を押す前に｢OK｣ ボタンを押してしまった場合には、「Undo」を行って下さい。

  ここで、収差の状況を見てみましょう。｢ツール｣－｢収差図｣－｢縦球面収差図｣ を選択すると、縦球面収差図のウィンドウが起動します。
  大きく右に流れていますね。ちょっとスケールを変更しましょう。｢スケール｣ の横にあるボックス内に ｢10｣ と入力して [Enter] キーを押すと、Ｘ軸の値が変更されて、この場合見やすくなります。
  ベンディングで少し収差を取り除いてみましょう。まず、縦球面収差図ウィンドウの ｢Data｣－｢Bending｣ でベンディングウィンドウを出します。このとき像面湾曲図等の「最大入射角」を聞いてきますので、°の欄に「１」あたりを入れておきましょう。

  ベンディングウィンドウでは、左に上から球面収差図、非点収差図、歪曲収差図が表示され、右上にはデータ表が示されています。
  色収差もかなりあるようなので、はじめは２面目と３面目でベンディングしましょう。
カーソルを表の上にもってくると「ベンディング 面１を選んでください」というヘルプメッセージが出ますので、データ表の中のNo. の列の ｢２｣をダブルクリックします。
２面目の色が黄色に変わり、続いてメッセージが「ベンディング面２を選んでください」に変わるので、データ表の中のNo. の列の ｢３｣ をダブルクリックします。
すると、３面目の色も変わり、下のスクロールバーが使用可能になります。 かなり値を変更する必要があるので、スクロールバーの下の Interval を ｢0.0003｣ 程度にしておきます。
  スクロールバーのつまみをマウスでつかんでそのまま右の方へ持っていくと、各色の線の間隔が短くなり、右端に近いところで赤のＣ線と青緑のＦ線がほぼ重なるところがあります。
ここでいったん ｢焦点距離調節｣ ボタンを押して、焦点距離を 1000mm に戻しましょう。
  さらに ｢選択解除｣ ボタンを押してベンディング面の指定を解除し、今度は１面目と２面目を指定します。
次にスクロールバーのつまみを少し右に持っていくと、球面収差曲線がほぼ垂直になります。｢OK｣ ボタンを押し、焦点距離変化の警告に対して ｢はい｣ を選択してウィンドウを閉じ、さらに縦球面収差図を ｢フォーム｣－｢閉じる｣ で閉じます。
  しかし、縦球面収差図の点線を見てみても、「ツール」－「３次収差係数」 で３次収差係数表を見ても、かなりコマ収差が残っているようです。

その３へ


使い方の例　その３

    今度は最適化をかけてみましょう。まず No.2 の ｢LFix｣ をダブルクリックしてチェックを外し、レンズ間距離を変更できるようにします。あまり近づきすぎるとまずいので、最小距離として 0.3 を入れておきましょう。
  次に ｢ツール｣－｢最適化｣－｢条件設定｣ を選択し、条件設定ダイヤログを起動します。
  ここで、まず左の波長のところはＣ線からＦ線までを 1 で残し、その他を 0 にしましょう。中央の各係数の欄は、補正すべき ｢Coma｣ のところに ｢1｣ を入れましょう。
  その他はそのままで良いでしょう。｢OK｣ でボックスを閉じ、 ｢ツール｣ －｢最適化｣－｢実行｣ で最適化を実行します。運が良ければ一回でかなり良い線まできます。収差図ウインドウ上の球面収差図で確認しましょう。
スケールには ｢５｣ を入れ [Enter] キーを押します。多分コマ収差はほぼなくなっているものと思います。その代わりに C線と F線が少し離れたようです。
   再び ｢ツール｣－｢最適化｣－｢条件設定｣ を選択し、｢Coma｣ のところは ｢0.4｣ 程度、 ｢F線｣ のところは ｢0.6｣ 程度にしてみましょう。
上と同様の手順で最適化を行うと、かなり目標に近づいてきていると思います。そのまま何度か最適化を繰り返すと良いでしょう。あと、Bending を適当に組み合わせて下さい。


データ入力の必要な項目

  データ表で最低限入力の必要な項目は、以下の通りです。
・d 線の屈折率 － これは、硝種または Air、Mirror を表から選択す れば自動的に入ります。
・面の曲率半径 － 平面 (0) は入力しなくてもかまいません。
・面の有効径 － No.0 の面は入力しなくてもかまいません。また、No.0の面に入力した値は計算時に空欄の面にコピーされます。
・面間距離 － 空欄の場合には 0 が入ります。

その他の欄は、必要に応じて記入して下さい。
なお、最終面の距離は、初めは空欄にして下さい。


収差図の見方

  8cm F6.7 のED 屈折レンズを例にとって見てみましょう。
まず「ファイル」－「open」で、Lens フォルダにある「Ed80.ldt」を選びます。

メイン画面で上の中央やや右の収差図アイコンをクリックすると、収差図ウィンドウが出ます。

はじめは見慣れた縦球面収差図が出てきます。ちょっと横に広がっているので、スケールを倍の「１」に広げましょう。この線がまとまっているほど球面収差は少ないといえます。
上のタブで、となりの横球面収差図を選びます。この図は像面に紙やフィルムをもってきたときの、横方向の広がりを示します。縦軸がその広がりで、縦への広がりが小さいほど収差が少ないことになります。左下の「焦点位置」の上下の矢印をクリックすると、最適な焦点位置を調べることができます。このレンズの場合は、+0.02mm あたりであるようです。

非点収差図、歪曲収差図を選んだ場合には、初めに最大入射角度を入れるダイヤログが出ます。とりあえず、「１」度を入れておきましょう。非点収差および像面の湾曲は多少見られますが、歪曲収差はないことがわかります。

スポットダイヤグラムを選ぶと、ある焦点位置及び光線のある入射角度での像がわかります。焦点位置は 0.02～0.04mm あたりでスポットが一番小さくなるようです。また入射角 1°ではスポットが奇妙にゆがみ、最良の焦点位置は -0.14mm あたりになります。

つづきへ


波動光学的像面図の使い方

続いて、波動光学的像面図（点像分布表示図）の使い方をみてみましょう。

収差図ウィンドウで「波動光学的像面」のタブを選択すると、入射瞳分割数ダイヤログがまず起動します。デフォルトでは、FFT サイズは 256、入射瞳分割数は 32 になっていますが、メモリやパワーが不足していない場合には上向きボタンを押して、それぞれ 512 と 64 にして、[Execute] ボタンを押してみましょう。下の進行表示バーが進み、しばらくすると像面図が現われます。中央の星像以外に回折リングが何本か見えています。

ここで入射角の上向きボタンを押して、入射角を１°にしてみましょう。再び進行表示バーが現われたのち、赤い奇妙な像が現われます。 スポットダイヤグラムや横球面収差図で調べてみると、赤いC線がフォーカス位置に来ているのがわかると思います。

再びタブで波動光学的像面を選びましょう。今度は入射瞳分割数ダイヤログで [OK] を選びます。今度は像面図は現われません。ここで焦点位置の下向きボタン を何回か押して、焦点位置を -0.140mm にしてみましょう。
上の計算機アイコンを押すと計算が始まり、今度は縦に黄色と緑、横に赤の像になります。

もう少し広い範囲を見るには、スケールを変えます。上向きボタンを押すと、 しばらくして倍の範囲の像面図が現われます。もう一度押し て横幅 0.2mm にしたときには、図は画面中央にしか現われません。こういうときには、もう一度計算機アイコンを押してみましょう。
今度は図が画面全体に出てきます。さらにスケールを広げて横幅 0.4mm にすると、両端は白いままです。計算機アイコンを押してももう図は広がりません。入射瞳分割数が 64 の場合はこれが限界です。

上の格子模様の FFT サイズ変更アイコンを押して、入射瞳分割数に 256 を入れてみましょう。[OK] ボタンを押し計算機アイコンを押すと、計算が始まり像面図が現われますが、今度は像面に変な格子模様が現われます。
ちょうど像面の分解能が落ちたような表示ですが、これは入射瞳分割数と FFT サイズの比が小さいときに起こります。

もう一度入射角を0°に し焦点位置を 0mm にして、スケールを 0.05mmに戻し、FFT サイズ変更のアイコンを押して、FFT サイズを 256 にし、入射瞳分割数には 16 を入れて [Execute] ボタンを押してみましょう。
すると、像面は滑らかですが、第２回折リングの外側に規則的な変な模様が現われます。
FFT サイズを 512 に、入射瞳分割数を 32 に変更すると、この模様は消えます。像面の滑らかさは同じでも、FFT サイズが小さすぎると偽の像が現われるようです。

次に、「View」－「像強度曲線表示」を選んでみましょう。左下に [再表示] ボタンが現われ、これを押すと点像強度分布曲線が現われます。ちょうど横線上の明るさを示しています。星像と回折リングの中間が落ち込んでいませんが、これは多波長の計算を重ねているからです。波長選択アイコンで単波長を選び、適切な焦点位置を選ぶと、見慣れた点像強度分布曲線になります。


スクリーンファイルの使い方

反射鏡を例にとって、スクリーンファイルの使い方をみてみましょう。データ例として、
http://yamachan.la.coocan.jp/File/vanecal.lzh
にあるファイルを使ってみましょう。
「Open」で Vanetest.ldt を選んでデータを見ると、No.3 の Mirror の前に「Screen」 面が入っています。データには斜鏡が入っておりませんが、斜鏡の影の分として中央に直径 50mmの遮蔽物が入っています。

収差図アイコンをクリックすると、スクリーン用ファイルを尋ねてきますので、 「4Vane1.txt」 を選んでみましょう。なお、この 4Vane1.txt ファイルは256×256の要素のうちまん中の縦横１行ずつが影の部分になっており、これが縦横それぞれ 256mm 角の面のうちの斜鏡支持脚分の１mm 厚に相当するようにしておりますので、データファイルでスクリーン面の有効径が 256mm になっていたわけです。
メイン画面でスクリーン面の有効径を 200mm に変えると、斜鏡支持脚の影の厚さは 200／256 = 約 0.78mm ということになります。
縦球面収差図が出てきますので、上のタブで右端の波動光学的像面図を選びます。入射瞳分割数は、とりあえずそのままにして [Execute] を押してみましょう。

何の変哲もない回折像が現われます。のちの計算速度低下に備えて、波長選択ダイヤログで、C、d、F、g の４色のみ選んでおきましょう。すぐに、多少色の変化した像が出ます。
もう少し周囲まで見るためにスケールの上向きボタンを押して、スケールを 0.1 にします。
淡いところまで見るために、像面輝度の上向きボタンを押すと、暗い部分が明るく強調された像が出ます。これをさらに２回繰り返すと、 周囲に変な模様が出ますが、斜鏡支持脚による回折像はわかりません。

FFT サイズをもう少し大きくしてみましょう。格子模様のアイコンを押して入射瞳分割数ダイヤログを出し、FFT サイズの上向きボタンを２回押して、サイズを 1024 にします。入射瞳分割数は自動的に 128 になります。ここで [Execute] を押すと、しばらく時間がかかったあとに像面が出ます。明るさは元に戻っているので、上向きの像面輝度ボタンを３回押してみましょう。像面が表示される前に押すとエラーが出ますので注意して下さい。

今度は縦横になにやら模様が出てきます。スケールの上向きボタンを押して 0.2 にすると、はっきりしてきます。このままだと左右が切れているので再計算アイコンを押してもう一度計算しなおすと、今度は斜鏡金具による回折像がよりはっきりわかると思います。


MTF 図の使い方

波動光学的像面図で MTF を見てみましょう。
MTF 表示ボタンが出ていない場合には、上の MTF アイコンを押してから計算機アイコンを押して再計算して下さい。

左の MTF 表示ボタンを押すと、MTF 図ウィンドウが現れます。縦軸はコントラスト値、横軸は空間周波数値です。横軸の右端は、選択した波長のうちもっとも短い波長で MTF が理想光学系において 0 になる空間周波数です。下の「Scale」 をクリックしてこの数値を変えてみましょう。
最大表示空間周波数ダイヤログが出てきますので、「200」を入れて 「OK」を押しましょう。すると横軸の最大値が 200 本／mm に変わります。

図中の各色の線は各波長での MTF 値、太線は白色光 MTF の値で、後者は、各波長での値に、上の「Spectrum」のボタンを押すと出てくる各波長の感度曲線で定義した重みの値を掛けたものです。

次に、最適焦点位置を求めてみましょう。
上のタブで「焦点位置」を選ぶと、表示する空間周波数の値を聞いてきます。デフォルトは 10 本／mm で、表示色は黒です。その下をクリックすると行が増えるので、左に「30」を入れ、右の黒い部分をダブルクリックして色の設定ダイヤログを出し、赤色を選 んでみましょう。さらに表の行の下をダブルクリックし、「50」 を入れ、色は青にしましょう。さらに同様の手順で「100」、黒を入れます。
「OK」を押すと、次は MTF 空間周波数記録最大値を尋ねてきますので、200 のまま「OK」を押します。

その次に「焦点計算開始位置」を聞いてきますので、ここでは「-0.05」を入れて「OK」を押し、「焦点計算間隔」は「0.01」のまま「OK」を押し、最後の「焦点計算数」には 「11」を入れて「OK」を押します。

かなり待たされた後に、焦点位置に対する、10 本／mm、30 本／mm、50 本／mm、100 本／mm の空間周波数でのコントラスト値曲線が出ます。
「Ed80.ldt」の例ですと、惑星向きの空間周波数の小さなところでは +0.03mm あたり、二重星向きの高解像度領域では -0.03mm あたりのコントラストが一番高いことがわかります。

ここで、右から２／10 あたりのところをダブルクリックすると、焦点位置指定ダイヤログが出てきて、中には「0.03」と入っていると思います。「OK」を押してタブで「空間周波数」を選ぶと、焦点位置 +0.03mm における白色光 MTF 曲線が出てきます。

入射角に対する各空間周波数でのコントラスト値曲線も、同様の方法で出すことが可能です。

上のドアアイコンを押して MTF 図を終了すると、波動光学的像面図ウィンドウに戻り、図中の焦点位置や Angle は先ほど指定した値に変化していますが、図自体は計算機アイコンを押して再計算しないとこれらの条件に当てはまる図にはなりませんので、ご注意下さい。


メイン画面

起動時にはレンズデータの表が表示されます。インストール直後は空のデータ（１面目(平面)のみ表示）が出ます。２回目からの起動時には、前回編集中のデータが出ます。

起動時に前回編集中のデータを出さないようにするには、「ファイル」－「new」を実行してデータが空の状態で「ファイル」－ 「Save Inifile」を実行しておいて下さい。


データ表の説明

データを読み込んだ後のデータ表です。表中をクリックすると説明が出ます。

データ表の変更したいところにカーソルをもってきて数値を入れると、データが変更されます。

・第一面目は固定です。有効径等以外の変更はできません。消去できないようになっているはずですが、消去しないで下さい。
・有限位置の物体を対象とするときには、第一面目 (No.0) の硝種のセルをダブルクリックして下さい。物体位置選択ダイヤログが起動します。
・変更したい面の硝種の行のセルにカーソルを持ってきて、[ENTER]キーを押すか、又はダブルクリックすると、硝種表選択ダイヤログが表示されます。
・曲率半径は、＋が左に凸、－が右に凸です。もちろん数値が大きいほど平面に近づきます。０は例外的に平面を表します。
・No.0の面の有効径に数値が入っていない場合には、No.1 以降の面の有効径には必ず数値を入れて下さい。
・口径はレンズ断面表示の際に使用されます。空欄の場合には有効径が代入されます。
・遮蔽の径は、斜鏡の影、反射鏡の中央穴などがある場合にその数値を入れます。空欄の場合は 0 です。
・距離には、次の面までの距離を入れます。
・焦点距離の変更時や自動修正のときに、ある面の曲率半径又は間隔の数値を固定したい場合にはその次の列の Fix をダブルクリックするかセルを選んで [ENTER] することによってできます。そのときにはセルにチェックマークがつきます。
・最大距離、最小距離は自動修正の最適化の際に用いられます。最大距離は軸上での次の面までの距離ですが、最小距離はレンズ口径内で次の面に最も近いところの距離（凸レンズの場合はレンズ端の厚さ）になっています。


データ表の説明２

データ表を右にスクロールしたところです。表中をクリックすると説明が出ます。

・軸外し光学系や、公差の見積もりのためにシフトまたはティルトを行う場合には、ここに数値を入れます。
省略時は 0 となります。


データ表の説明３

データ表をさらに右にスクロールしたところです。表中をクリックすると説明が出ます。

・非球面係数は、k 及び A4～A14 で示されます。
・屈折率の値は、硝種を選択すると自動的に入ります。


データ表の説明４

データ表をいちばん右までスクロールしたところです。表中をクリックすると説明が出ます。

・屈折率の値は、硝種を選択すると自動的に入ります。
・備考の欄には硝子メーカ名等を入れます。この欄が空欄でないと、屈折率の値を変更することはできません。また、Glass で「絞り面」または「焦点面」を選んだときには、ここに記入されます。


メイン画面ショートカットアイコン

各アイコンをクリックすると説明が表示されます。


非球面係数

k、A4～A14 の非球面係数は次式で表されます。

Aspherical eqn

h は光軸からの距離、r は曲率半径になります。

非球面係数は４次から 14次まで入力可能です。
高次の非球面係数 A4～A14 が 0 のときには、
k < -1 のときは双曲面、
k = -1 のときは放物面、
k > -1 のときは楕円面になります。
k = 0 のときには通常の球面です。


屈折率の入力

屈折率の値はガラスを選択すると自動的に入ります。
変更したい面の硝種の行のセルにカーソルを持ってきて、[ENTER] キーを押すか、又はダブルクリックすると、硝種表選択ダイヤログが表示さ れます。

ただしデフォルトでは住田光学の表しかありません。OHARA、HOYA、Schott はデータを入手してください。それ以外のガラスは手動入力になります。
屈折率は表のかなり右の方にありますので、右にスクロールして下さい。
入力・変更したいところにカーソルをもってきて数値を入れると、データが入力・変更されます。

注：表の一番右の備考 の欄が空欄でないと、屈折率値の入力及び編集はできません。編集の際は、スペースも含めすべての文字を[Delete]キーで消去し て下さい。
また、一番上の No.0 の面は編集できません。

表示する必要のない波長の屈折率値は入力する必要はありません。

また表にない波長の屈折率を計算して用いることもできます。


有限距離の光源

近距離にある物体からの光線を追跡することができます。至近距離にあって焦点を結ばないときには警告のダイヤログが出ます。

データ表の一番上の行（No.0 面）の硝種の列をダブルクリック又は 選択後に [Enter] を押すか、カーソルが No.0 面にあるときにメニューの「データ」－「Glass」 を選択すると物体位置選択ダイヤログが起動します。ダイヤログ中で「有限距離」 のボタンを選択すると、No.0 面が「Object」になり、備考欄に「有限距離」と記入されます。
有限距離の場合には、曲率を指定することができます。デフォルトは 0（平面）です。

もともと無限遠の物体を対象にプログラムを組んでおりましたので、多少使いにくくなっております。


裏面反射鏡

データ表で硝種選択の際に「Mirror」を選んだとき、前面の硝種の欄が「Air」でない場合（前面の屈折率が１以外の場合）には、裏面反射鏡になりま す。
確認のダイヤログが出るので、「はい」を選んで下さい。
（「いいえ」を選択した場合には普通の鏡面となりますが、その際にはもう一面前面に空気面の挿入が必要です。）

裏面反射鏡を選択すると、自動的に
・硝種欄は「2nd Surf Mirror」となります。
・裏面反射鏡の屈折率は前面の硝種の屈折率に負号をつけたものになります。
・次面までの距離は前面から裏面反射面までの距離となり、距離固定の欄に前面のNo.が入ります。
・裏面反射面の口径、有効径は前面と同じになります。
・裏面反射鏡の次の面として空気面が挿入され、曲率、口径、有効径、非球面係数は前面と同じになり、曲率の固定欄に前面のNo.が入 ります。

前面がさらに貼り合わせ面である場合などデータが違うときには修正して下さい。


焦点面

データ表の中に焦点面を記述する必要はありません。
最終面から焦点面までの距離（最終面の｢距離｣の項目）は、はじめは空欄にして下さい。d 線の近軸光線の焦点位置から自動的に計算されます。

焦点面をデータ表に明示することもできます。このときには、面を追加した後硝種表選択ダイヤログ又は｢デー タ｣－｢glass｣から ｢焦点面｣を選択して下さい。このときも最終面から焦点面までの距離は空欄でかま いません。
シュミット光学系などの湾曲した焦点面のときには、適切な曲率半径の値を入れて下さい。
焦点面の非球面係数は無視されます。


絞り面

絞りの位置がここになります。レンズ系の主光線の位置を決めるのに用いられます。断面図の軸外光線表示や３次収差係数の計算等にも主光線が用いられます。
絞り面を指定しないときには、レンズ 1 面目（反射鏡の場合は反射面）が絞り面と見なされます。

屈折率値は、硝種に｢Air｣を選択したのと同じく、1 が入ります。


軸外し光学系、公差等について

面の座標の指定は、下の図のようになっています。
軸外し光学系

光軸をずらしたり傾けたりする面 ( i+1面) は、前の i 面の座標を基準に指定します。
i+1面の原点 O' の元の位置からのずれは、dx、y または dy、z または dz で表されます。軸外し光学系のときには y、z に、公差の見積もりのために光軸をずらすときには dx、dy、dz に数値を入れて下さい。
光軸 (x 軸) が傾くときには、傾きの角度 (x''O'x') の角度をθ (Theta) で、傾きの方向 (図では少しわかりづらいですが、元の xy 平面と x''O'x' 平面のなす角度) をφ(Phi) で指定します。角度の数値は度 (ﾟ) で入れて下さい。
公差の見積もりのために光軸を傾けるときには、Theta、Phi の欄でなく dTheta、dPhi の欄に数値を入れて下さい。

i+1面の光軸は、その後ろの面すべてに有効になります。反射面の場合はこちらを 見て下さい。

公差の見積もりのためにある面又は一部のレンズ系のみをずらす場合には、その後ろの面で光軸を元に戻す指定が必要です。｢データ｣- ｢Shift, Tilt｣ を選択すると自動でその値が計算されます。

なお、平面鏡以外の軸外し光学系では、まともな球面収差図は表示されません。


斜鏡等について

斜鏡等の反射面では、その先の光軸は反射面に垂直な面ではなく、軸上光線の反射方向になっています。したがって、斜鏡を通ったあと (接眼部等) にレンズ系を入れる場合などは、斜鏡の面の Theta に角度 (45 等) を入れる以外の操作は不要です。

なお、斜鏡の径には短軸径でなく長軸径を入れて下さい。現在、斜鏡径による正確なケラレは表示できておりません。
斜鏡等による影には、データ例のように、前方に別に絞り用の面を挿入して下さい。


面の追加

現在の表の下に新たな面を追加するときには、カーソルを一番下の行にもってきてさらに下向きの矢印キーを押すか、下の空欄をクリックするとできます。
その他の方法としては、編集の面を追加、面を挿入の項を参考にして下さい。


データ編集の途中で

データ編集の途中で 編集中にツールの各計算を行った場合には、ｄ線の屈折率（nd）が記入されていない面は自動的に削除されます。
また、No.0 面または各面の有効径が記入されていない場合には、記入のためのダイヤログが起動します。適当な値を入れて下さい。

各計算でははじめに焦点距離が計算されますが、焦点が存在しない場合には警告のダイヤログのみ出ます。

編集の途中でデータを保存せずに終了した場合、Inifileで指定していない場合は次回起動時にはデフォルトで編集途中のデータが 表示されます。


Inifile

フォントなどを実行時に変更した場合には、それらの設定を Inifile に保存することができます。デフォルトでは Inifile はなく、また Inifile が無い場合には各設定はデフォルトの値が用いられます。
Inifile はメイン画面、収差図ウィンドウ、断面図ウィンドウ上で Save Inifile を実行すると保存（又は生成）されます。どこで実行しても作成される項目は同じです。

Save Inifile を実行した場合、デフォルトと同じ設定の項目は記入されません。

テキストエディタ等で Inifile を編集すると設定を変えることができます。項目を消去した場合にはその項目はデフォルト値が用いられます。全部デフォルト値に戻す場合には、 Inifile を消去して下さい。

なお、ガラスデータ名はデフォルトでは Sumita.txt、Ohara.txt、HOYA.txt のみ認識されますが、Inifile を編集して「Sumita=ooo.ooo」「Ohara=ooo.ooo」「HOYA=ooo.ooo」など、たとえば「HOYA=data.csv」 を入れると、それらの名前のファイルを認識するようになります。


スクリーン

ニュートン式反射鏡の斜鏡支持金具などの、光軸に対して同心円形状でない影の影響などについて、スクリーンファイルを用意して調べることができます。スク リーンファイルとしてタブ区切りテキストファイルを用意して下さい。
スクリーンによる効果はスポットダイヤグラム及び波動光学的像面図にのみ現れます。

スクリーン面の有効径は作成したスクリーンファイルの想定するサイズにして下さい。スクリーンのサイズを入射瞳サイズの 1.1 倍と考えて作成した場合にはその数値を入れて下さい。
有効径が入射瞳サイズよりも小さい場合には光のケラレが生じます。

スクリーン面を含む光学系についてツールの計算を行うと、初めにスクリーンファイルの名前と場所を聞いてきますので、指定して下さい。ファイルを指定せずにキャンセルしたり存在しないファイルを指定した場合には、スクリーン面は空気面に変換され、そのまま計算が進行します。スクリーンファイルでない誤ったファイルを指定するとエラーになります。
なお、デフォルトディレクトリに Screen.txt の名前でファイルを保存しておくと、ファイルはそのまま使用されます。複数のスクリーンを使い分ける場合には、Screen.txt というファイル名のものを作らないで下さい。


スクリーンファイルの作り方

スクリーンファイルはタブ区切りテキストファイルにして下さい。表計算ソフトではタブ区切りテキストファイルとしてセーブできると思います。サイズは縦横を等しくして下さい。
本プログラムでは光線追跡の際に斜め入射光によるケラレが少なくなるように、スポットダイヤグラムや波動光学的像面図の追跡光線は入射瞳サイズの 1.1 倍の大きさをとってあります。
スクリーンを入射瞳位置以外に置く場合には、スクリーンサイズは入射瞳サイズの 1.1 倍に取ればよいでしょう。たとえば口径 10cm のレンズにスクリーンを置き、0.5mm 間隔で透過率を決める場合には、10cm×1.1÷0.5mm で、220 行×220 列のサイズのファイルになります。

テキストファイル中の数値は、0～255 を入れて下さい。不透明な部分は 0 で、ファイル中に現れる最大の数値が透過率 100％になります。遮蔽物の影などを表す場合には、「0」と「1」のみで表現すると良いでしょう。１つでも「2」があると、1 の部分はすべて透過率 50％とみなされます。
行列サイズは偶数にして下さい。下は、十字の影のある 10×10 サイズのスクリーンの見本です。

1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1
0 0 0 0 0 0 0 0 0 0
1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1
1 1 1 1 1 0 1 1 1 1

部分的に透過率に差のあるフィルタを表す場合には、それぞれの部分で透過率に合わせた数値を入れて下さい。10 段階で表す場合には 0～9、100 段階の場合には 0～99 を入れると良いでしょう。

光線追跡時にスクリーンのメッシュサイズと追跡光線のメッシュサイズが合っていない場合には、それぞれの光線について付近のスクリーン値の平均が透過率とみなされます。たとえば、下の図で実線で区切られているところがスクリーンメッシュ、黒丸が追跡光線位置とすると、左上の光線の透過率は 1、左下と右上は約 0.5、右下の透過率は約 0.02 と計算されます。

Example of Screeen

スポットダイヤグラムでは、0 以外の値はすべて 100％透過とみなされます。


データファイルについて

デフォルトで *.ldt の拡張子をもつレンズデータは、タブ区切りのテキストデータです。
表計算ソフトなどで編集でき、行や列の追加や列の順序の入れ替え（プログラムのデータ表には反映されません）も可能ですが、左端の No. 及び右端の備考の列は両端から動かさないで下さい。また一番上の項目名でデータの順序を判断していますので、同じく表計算ソフトなどで編集する際には項目名は変更しないで下さい。

バージョンアップによる形式変更の場合でも、上位下位互換は保たれております。
古いデータファイルを読み込んだ場合、新バージョンで新たに追加された項目の欄ははじめ空白になります。


New

新規データの編集を行います。１面目の平面のみ表に残ります。
既存データをセーブしていない場合、データを保存するか破棄するかを尋ねてきます。


Open

ディスクからデータファイルを読み込みます。
デフォルトでは、\Lens フォルダにある *.ldt ファイルが表示されます。


Save

現在のデータを、オープンしたファイルの上に上書きセーブします。
新規作成データの場合には、Save As と同じになります。
データが保存された後に変更されていない場合には、無視されます。


Save As

データを保存します。
拡張子を付けてセーブして下さい。拡張子に *.ldt を用いると、データオープンの際に一覧に表示されます。


Save Inifile

設定を Inifile に保存します。保存されるのは各ダイヤログの大きさやフォント、自動修正の条件等です。


Exit

プログラムを終了します。


Undo

変更したセルのデータを元の値に戻すことができます。
Undoは一回のみです。次のセルを変更した後には前のセルのデータは戻りません。

場合によっては Undo が効かないことがあります。おまけの機能と思って下さい。


Cut

データの切り取りです。内容は Windows のクリップボードに入ります。

データ表セル内のデータの場合には、一つのデータ又は複数のデータ全部が切り取りされます。一部の数値を選択しても、クリップボード にはそのセル内のデータ全部がカットされています。


Copy

データのコピーです。内容が Windows のクリップボードにコピーされます。

データ表セル内のデータの場合には、一つのデータ又は複数のデータ全部がコピーされます。一部の数値を選択しても、クリップボードに はそのセル内のデータ全部がコピーされています。


Paste

クリップボード内のデータを選択したセルに貼り付けます。

データ表セル内のデータの場合には、一つのデータ又は複数のデータ全部が貼り付けされます。


複数セルの選択

Cut 又は Copy が複数セルにわたって選択できるようにします。
これを選ぶとセル内の数値の変更ができなくなりますので注意して下さい。


セル内容の編集

新規セルへの数値の入力や、既存セルの数値の変更ができるようにします。
デフォルトではこちらが選択されています。


面を追加

データ表の一番下に新たな面を追加します。カーソルを一番下の行にもってきてさらに下向きの矢印キーを押すか下の空欄をクリックし た場合と同じ動作をします。


面を挿入

現在のカーソルのある面の行の上に新たな面を挿入します。カーソルが 第１面目（No.0）にあるときには選択できません。


面を削除

カーソルのある面を削除し、その下の面は順に上に詰めます。第１面目（No.0）は選択できません。


Memo

ウィンドウの右下に Memo を表示します。レンズ名等、メモを残しておきたいことがらを記入して下さい。
表示時にもう一度 ｢表示｣－｢Memo｣ を選択すると、Memo の表示が消えます。

Save の際には Memo の内容はデータと共にファイルに記入されます。タブの有無でデータとの区別をしているので、Memo 内ではタブは使用しないで下さい。


直径→半径

有効径の入力値として、直径か半径かを選択します。
半径にすると、表示が「有効半径」「半径」「遮蔽半径」に変わります。
半径表示にした状態で「ファイル」－「Save Inifile」を実行す ると、起動時にいつも半径表示になります。

どちらを選択していても、データファイル内では直径値でセーブされています。


フォント

表のフォントを変更します。設定したフォントは３次収差係数の表にも適用されます。


Glass

カーソルのある行の面の右側の屈折率を決めるために、硝種の選択を行います。カタログの会社名を選ぶと 硝種表ウィンドウが起動します。

会社名はデフォルトでは住田光学のみです。オハラやHOYAはファイルをダウンロードして下さい。

｢Air｣又は｢Mirror｣ を選択すると、次の面（反射後の場合は左の面）の屈折率がそれぞれ１又は－１に設定されます。
｢絞り面｣又は｢焦点面｣ を選択した場合には、硝種の欄は Air になり備考欄にそれぞれ｢絞り面｣又は｢焦点面｣が記入されます。
｢スクリーン面｣は特別な遮蔽物がある場合などに用います。 スクリーン用ファイルを用意して下さい。これを選択した場合には、硝種の欄は Screen になり備考欄にはスクリーンと記入され、屈折率１がデータに入ります。

データ表の上で、ある面のガラス名セルをダブルクリックしたとき（このときは硝種表選択ダイヤログ が立ち上がります）と類似の動作をします。

No.0 面ではデータを選択してこの「Glass」にカーソルをもってくると自動的に 物体位置選択ダイヤログが起動します。


Shift, Tilt

公差の見積もりのために、面、レンズ、レンズ群の光軸をずらしたり (Shift) 、傾けたり (Tilt) します。

このメニューを選択すると、セルの選択が行ごとになり、「シフトまたはティルト開始面をダブルクリックして下さい」というヒントの表示が出ます。シフトまたはティルトを行う面をダブルクリックして下さい。
「シフトまたはティルト終了面をダブルクリックして下さい」というヒント表示に変わるので、シフトまたはティルトさせるレンズ系の最終面を選択してダブルクリックして下さい。一面のみをシフトまたはティルトさせる場合には、開始面と終了面が同じ面になります。

開始面、終了面を選択すると、dx、dy、dz、dTheta、dPhi の値を入力するダイヤログが出ますので、それぞれ必要な値を入れて下さい。単位は mm および度です。面の座標の入れ方については、こちらの図を参考にして下さい。

面の指定の途中で別のメニューを選択した場合には、シフト、ティルト面の指定はキャンセルされます。たとえばレンズ断面図を表示させて図を閉じた場合には、各セルごとの選択に戻っています。

dx、dy、dz、dTheta、dPhiの値が 0 でないデータをセーブしようとすると、警告が出ます。


再入射同一面の指定

反射後に同一面に入射する場合に使います。副鏡手前のレンズ系や裏面反射の場合などに用います。ベンディングの際に連動して変化するようになります。
現在のところ、指定方法は少しややこしくなっています。
なお、データ入力で直接裏面反射鏡を入力する場合には、以下の操作は不要です。

まず再入射面にカーソルを持っていってフォーカスを与えて（セルが濃色になり数字が反転表示、硝種や曲率半径などどの欄でも結構です）から、「データ」－「再入射同一面の指定」を行います。すると行全体が反転表示されます。
ここで再入射される同一面の行をダブルクリックすると、rFix の欄にその面の No. が記入され、曲率半径値にその面の値と同一の値が入ります。
はじめにカーソルを持っていく再入射面は必ず No. の大きいほうの面、あとで指定する同一面はそれよりも No. の小さな面にして下さい。

次に、再入射面の距離にカーソルを持っていってダブルクリックすると、再び行全体が反転表示になります。ここで同一距離の面をダブルクリックで指定してください。 lFix の欄に同一距離の面が記入されます。

これらの操作の代わりに rFix 及び lFix の欄に該当する数字を直接入力しても同じですが、入力を間違えるとベンディングの際に間違った欄のデータ値が変化します。

指定を解除する場合には、rFix 又は lFix の欄をそれぞれ２回ダブルクリックして下さい。

再入射の使用例は、データ例のvmc.ldtを見て下さい。


同一曲率面の指定

現在のところ、再入射同一面の指定と、操作法や機能はまったく同じで す。
ベンディングや最適化の際に指定面と連動して曲率が変化します。


波長挿入

デフォルトでは光線追跡可能な波長は、t 線、s 線、A' 線、r 線、C 線、d 線、e 線、F 線、g 線、h 線、i 線の 11 波長です。それ以外の波長の屈折率を計算して光線追跡するにはこの機能を使用します。

クリックして、「表にない波長の屈折率を計算しますか？」に「はい」を選んで、出てくるダイヤログに希望の波長を nm 単位で入れます。小数点以下があっても問題ありません。

「他の波長を追加しますか」に「はい」を選ぶと上の作業の繰り返しです。「いいえ」を選ぶか波長の入力で「キャンセル」を押すと終了します。
表の右端の屈折率のところに、波長の長い順に屈折率値が表示されます。

任意波長の挿入、追加は、新規データ入力前でも入力後でも可能です。ただし、「New」 や「Open」でデータ表を空にしたり追加波長のないデータを新たに読み込むと追加波長はキャンセルされ元の状態に戻ります。

波長を追加したデータを「Save」すると、追加波長の屈折率データも保存されます。このデータをもう一度読み込むと、その追加波長 も読み込まれます。

使用している硝種表にデータ表上の硝種名がない場合には屈折率は計算され ません。その場合には、現在の各社の硝種表上で新たにガラスを選択し直して下さい。

なお、ここで指定した波長については、そのままでは収差図上ではその短波長側の表示色と同じ色で表示されます。 波長選択ダイヤログを用いて適当な表示色に変更して下さい。


３次収差係数

３次収差係数の表のウィンドウを起動し、数値を表示します。

焦点が無い場合には警告のダイヤログが出、３次収差係数表は出ません。


収差図

縦球面収差図、横球 面収差図、非点収差図、歪曲収差図、波面収差図 （Line）、波面収差図（面）、波動光学的像面図を選択すると、 それぞれの図が表示されます。

焦点が無い場合には警告のダイヤログが出、収差図は出ません。

球面収差図等が表示されるのは通常の共軸光学系のみです。軸外し光学系等では正しく表示されません。

なお、波動光学的像面図の表示には、収差図ショートカットアイコンボタンを押して収 差図を表示してから、収差図ウィンドウ上のタブによる選択を行って下さい。


スポットダイヤグラム

スポットダイヤグラムの図が表示されます。表示までにはレンズ面数に応 じて多少の時間がかかります。

焦点が無い場合には警告のダイヤログが出、スポットダイヤグラムは出ません。


レンズ断面図

レンズの断面図を表示します。

焦点が無い場合には警告のダイヤログが出、レンズ断面図は出ません。


焦点距離

レンズの焦点距離ダイヤログを表示します。ダイヤログ内で焦点距離を変 更した場合には、｢Fix｣ の欄をチェックしていない曲率半径及び距離は変更されます。Fix されたデータがある場合、収差の状況が変化するので注意して下さい。


条件設定

最適化条件設定ダイヤログを起動します。一度選択して起動しないと、下 の｢実行｣は選択できません。


実行

最適化を実行し、収差が小さくなるようデータの最適化を行います。
先に条件設定ダイヤログを起動して｢OK｣ボタンを押さないと、選択 できません。データ初期値と乱数の関係で一度実行してもあまり最適化されないことがあります。何度か繰り返し試行 して下さい。

最適化の前には念のためにデータをセーブしておいて下さい。

すべての曲率及び面間隔データが固定されているときには、「実行」はできません。
本プログラムの最適化では、条件設定でチェックされている状態では焦点距離は変化しません。


目次

このヘルプの目次が起動します。


ヒント表示

チェックをオンにすると、ヒントとして各セルの説明が表示されます。
数値の入力のじゃまになるときにはオフにして下さい。


バージョン情報

本プログラムの Version を表示します。


物体位置選択ダイヤログ

有限距離の物体を対象とするときに指定します。

メイン画面で、データ表の一番上の行（No.0 面）の硝種の列をダブ ルクリック又は選択後に [Enter] を押すか、カーソルが No.0 面にあるときにメニューの「データ」－「Glass」 を選択するとと起動します。

デフォルトでは無限遠が選択されています。有限距離の物体を対象にするときには、下の有 限距離のボタンを選択して下さい。No.0 面が「Object」になり、備考欄に「有限距離」と記入されます。

さらに No.1 面として空気面が挿入されますので、距離のところに物体からレンズ１面目までの距離を入れて下さい。
距離を入れずにツールメニューのどれかを選択した場合には、距離の入力を促するダイヤログが現れます。短すぎる距離を入力して焦点を 結ばない場合には警告が出ます。

有限距離が選択されているときにこのダイヤログを出して「無限遠」を選 択すると、No.0 面の消去を確認するダイヤログが出、「OK」すれ ば No.0 面は消去されます。新たな No.0 面には先ほどのレンズまでの距離が入ったままになっているので注意して下さい。


硝種表選択ダイヤログ

メイン画面で、データ表のガラスを選択したい面の行のうち、硝種の列 をダブルクリックすると起動します。

｢Sumita｣ボタンを選択すると、住田光学の硝種表ウィンドウが起 動します。
｢Ohara.txt｣又は「HOYA.txt」、「Schott.txt」が本プログラムと同一フォルダ上にある場合には 「Ohara」又は「HOYA」、 「Schott」 も選択可能です。
その他のメーカや現在の硝種表にない硝種の場合には、データの入力を参考に、ご自分で数値を入れて下さい。

｢Air｣ボタンをクリックすると屈折率１が、
｢Mirｒor｣ボタンをクリックすると屈折率－１がそれぞれデータに 入ります。

｢絞り面｣ボタン又は｢焦 点面｣ボタンをクリックすると、備考欄に記入され、屈折率１がデータに入ります。

｢スクリーン面｣は特別な遮蔽物がある場合などに用います。スクリーン用ファイルを用意して下さい。ボタンをクリックすると、備考欄に 記入され、屈折率１がデータに入ります。


焦点距離ダイヤログ

メインメニューで ｢ツール｣－｢焦点距離｣ を選択すると起動します。
このダイヤログで焦点距離を変更します。この説明を読んで、注意して使用して下さい。

テキストボックス内には現在の焦点距離が表示されます。焦点距離を変更したい場合には、ここに値を記入して｢OK｣ボタンを押します。データの曲率半径及び面間隔距離が比例して変更され、 希望の焦点距離になります。
曲率半径又は距離に Fix のチェックが入っているときには、その値は変化せず残りの値だけ比例して変化して焦点距離を合わせるようになっています。このときには収差の状況も変化し てしまうことに注意して下さい。
変更した値が気に入らないときには、｢編集｣－｢undo｣を選択すれば、バックアップされた元データがロードされます。

Fixのチェックの入った面が多いときには、焦点距離の変更がうまくいかないことがあります。このようなときには、何回かに分けて焦 点距離を少しずつ変化させて下さい。なお、Fix された面によってはどうしても焦点距離が希望の値に達しないことがあります。


波長選択ダイヤログ

収差図等で計算、表示する波長を選択します。
硝種表にデータのない波長は選択できません。住田光学のカタログではｓ線 がありませんので、ｓ線は選択できません。

各波長の表示色は変更できます。各波長で左の色の部分をクリックすると、色の設定ダイヤログが立ち上がりますので、希望の色を選んで 下さい。

硝種表にない波長の屈折率を表示させた場合には、そのままでは表示色はそ の下の波長と同じ色になっています。適宜変更して下さい。

表示色は、下のほうの「RealColor」ボタンを押すと、波長値か ら計算される実際に近い色に変わります。そのあとに右に現れる「 WhiteBalance」 ボタンを押すと、表示色全色を合成したときにちょうど白色になるように明るさが調整されますが、色はやや暗く見難くなりま す。
波動光学的像面図の表示の際などにお使い下さい。

波面収差図の場合には選択ボタンの代わりにラジオボタンが現れます。計算したい一波長を選んで下さい。デフォルトではｄ線です。


ペン太さダイヤログ

収差図等、レンズ断面図でのペンの太さを指定します。
デフォルトは１で、１～５の５段階です。
印刷用には２程度が見やすいでしょう。


光線数設定ダイヤログ

ダイヤログ名は光線数／半径、または光線数／最大角 となっています。
収差図、スポットダイヤグラム等で計算、表示される光線数を決めます。
球面収差図およびスポットダイヤグラムで光線数／半径の場合は、数値は中心の次からレンズ周辺までの光線本数です。
非点収差、歪曲収差図で光線数／最大角の場合は数値は中心の次から設定した最大角度までの光線本数です。

選択したステップ数をＳとすると、収差図の場合にはＳ＋１本の光線、スポットダイヤグラムでは (２×Ｓ＋１)^2 本の格子上の光線のうちレンズ系に入って出てくる光線の数になります。
Ｓはデフォルトで収差図の場合は30、スポットダイヤグラムでは15で、２～40の範囲が選択できます。

なお、数値をダブルクリックすると最大で 512 を入力することができますが、大量のメモリと計算時間を必要としますので、不用意に実行しないで下さい。512 以上の数値を入力すると、512 に修正されます。


入射角間隔設定ダイヤログ

横球面収差図又はス ポットダイヤグラムウィンドウ等で ｢Option｣－｢入射角間隔｣ を選択すると起動します。

それぞれの図において、下の Angle の欄の右にある上下ボタンを押したときに、このダイヤログ内で設定された角度ずつ入射角が変わります。

なお、テキストボックス内には小数を入れてもかまいません。右の分の欄に60以上の数字を入れると、度の欄が再計算されます。


入射角表設定ダイヤログ

横球面収差図又はス ポットダイヤグラムウィンドウ等で ｢Option｣－｢入射角表｣ を選択すると起動します。

それぞれの図において、右下の ｢Next｣ ボタンを押したときに、入射角がこのダイヤログ内で設定された次の角度に変わります。

この表は、入射角０度、小角、中角、大角での状況の変化を見たいときに、それぞれの角度間隔が不等間隔のときに設定して用いると便利 です。
等間隔のときには入射角間隔を設定して上下ボタンで変化を見る方が簡便で す。
また Bending においてスポットダイヤグラム変化を表示したい場合には、この表の上から３つまでの入射角について表示されます。

この表は、左が度、右が分で、それぞれの欄に小数を入れてもかまいません。右の分の欄に60以上の数字を入れると、度の欄が再計算さ れます。

数値の変更は、変更したい欄をマウスでクリックして数字を反転させると行えます。
角度の追加には、表の下の空欄をマウスでクリックするか、一番下の行にカーソルがあるときにさらに下向きカーソル（↓）を押すと、新 たな欄が現れるので、そこに入力して下さい。設定できる角度は８個までです。
角度の消去は、下の ｢Delete｣ ボタンを押して下さい。確認のダイヤログが現れます。
また、度、分の両方の欄を [Delete] キーで消すことによっても行えます。


最大入射角設定ダイヤログ

非点収差図又は歪曲収 差図で ｢Option｣－｢最大入射角｣ を選択すると起動します。
それぞれの図における縦軸の最大角度を設定します。

このダイヤログでは、左が度、右が分で、それぞれの欄に小数を入れてもかまいません。右の分の欄に60以上の数字を入れると、度の欄 が再計算されます。
０またはマイナスの数字を入れると、収差図ウインドウが閉じてメイン画面に戻ります。


焦点位置間隔設定ダイヤログ

スポットダイヤグラムウィンドウ等で ｢Option｣－｢焦点位置 間隔｣ を選択すると起動します。

左下の焦点位置の欄の右にある上下ボタンを押したときに、このダイヤログ内で設定された値ずつ焦点位置が変わります。単位はメイン画 面のデータ表と同じで、通常はmmです。


入射瞳分割数設定ダイヤログ

波動光学的像面表示のための FFT プログラムの計算を行うために、FFT のサイズと入 射瞳位置での計算メッシュサイズを決めます。二次元 FFT のサイズは上の欄の数字になります。このサイズは、64～8192 まで選択可能です。上下ボタンを押す度に数値が２倍ずつ変化します。大きいほどコンピュータのメモリ及びCPUパワーを必要としますので、8192はお勧 めできません。
コ ンピュータのメモリが足りないときには警告が出ます。さらにハードディスクの空き容量も足りないときには メッ セージ が出て、計算はできません。

入射瞳位置でのメッシュサイズは入射瞳分割数の欄の数字になります。デフォルトでは FFT サイズの８分の１です。表示の数を N とすると、入射瞳×1.1 の領域に N×N 本の光線を通して波面収差が求められます。奇数値を入れると偶数に変わります。数値の決め方は「FFT サイズと入射瞳分割数」を見て下さい。

下の [Execute] ボタンを押すと、波動光学的像面の計算が実行されます。

[OK] ボタンでは分割サイズが確定され、元の収差図表示画面に戻ります。焦点位置や入射角などを後で設定したい場合にはこちらを選んで下さい。設定後には、収差 図表示画面の「計算」－「実行」 または上の計算機アイコンを選んで波 動光学的像面を計算して下さい。

[Cancel] ボタンは何もせずこのダイヤログを閉じます。


硝種表

メインメニューの｢データ｣－｢Glass｣－｢Sumita｣ 等を選択するか、硝種表選択ダイヤログで｢Sumita｣等を選択すると 起動します。「Ohara.txt」や「HOYA.txt」、「Schott.txt」が本プログ ラムと同一フォルダ上にある場合には「Ohara」又は「HOYA」、「Schott」 も選択可能です。

なお、住田光学の最新の表はホームページ、http://www.sumita-opt.co.jp/ja/index.htm の日本語ページの中のカタログデータダウンロードから入手して下さい。本ソフトに付属のデータファイル sumita.txt はダウンロードデータを表計算ソフト中でタブ区切りテキストファイルとしてセーブしたものです。


OHARAの硝種表について

OHARAの最新の光学ガラス表はホームページ、http://www.ohara-inc.co.jp/ の日本語ページの製品情報の中の光学ガラスページのカタログデータダウンロードから入手して下さい。数種のxls形式のファイルがあります。これらを表計 算ソフト上で連結し、タブ区切り又はカンマ区切りテキストファイルとして「Ohara.txt」という名前で セーブして下さい。

OHARAの硝種表が文字化けして見づらい場合には、メイン画面でフォントをMS Pゴシック等に変えて下さい。


HOYAの硝種表について

HOYAの最新の光学ガラス表はホームページ、http://www.hoya-opticalworld.com/ の日本語ページの製品情報の中の光学ガラスページのカタログデータダウンロードから入手して下さい。

ダウンロードしたHOYA*****.xlsxを表計算ソフト上でタブ区切り若しくはカンマ区切りテキストファイルとして 「HOYA.txt」という名前でセーブして下さい。
なお、HOYA*****.xlsxの中には不要な空白が入っていて硝種表ウィンドウでは見にくくなっていますので、空白を除いて再 セーブするのをお勧めします。
これらのファイルは sumita.txt と同じく LensCal のプログラムの入ったフォルダに入れて下さい。


Schottの硝種表について

Schottの最新の光学ガラス表はpdfファイルになっているようです。
何とかしてデータをデータ例Schott.txtのように表計算ソフト上に展開して形式を整えて下さい。

これを、必ず"Schott.txt”の名前でタブ区切り（又はカンマ区切り）テキストファイルとして保存し、LensCalと同じ フォルダに入れてご使用下さい。


表の見方

GTYPE：６桁の数字で、前３桁はｄ線の屈折率－１、後ろはアッベ数です。
GNAME：ガラス名
vd(νd)：アッベ数
nt～ni：各線の屈折率。ng(436nm)、nF(486nm)、nd(587nm)、nC(656nm)あたりが重要です。

現在選択されている硝種は、反転表示されています。その硝種について、名前、ｄ線の屈折率、アッベ数が左下に表示されています。

現在マウスカーソルのある位置の数値が右下に表示されます。表示枠をはみ出している数値については、右下で確認して下さい。


表のソート

デフォルトではガラスはウェブ上のファイルの通りの順で並んでいます。

３行目の黄色の行をクリックすると、その列の数値によって、昇順にソートされます。
たとえば nd のところをクリックすると、d線の屈折率の小さい順に並びます。
ただしすべて文字列として処理しているため、列によっては数値順にはソートされないときがあります。

ソート後は、現在選択されているガラスが表中に現れる位置にスクロールされます。


Select、Cancel

硝種の選択は、カーソルまたはマウスのクリックでできます。ただし、GTYPEやGNAMEの列をクリックしても何も起きません。 反転表示される部分をクリックして下さい。

｢Select｣ボタンを押すと、現在選択されている（左下に表示のある）硝種が選択され、メインウィンドウのデータ表中に入り、硝 種表ウィンドウが閉じられます。

｢Cancel｣ボタンを押すと、何もせずに硝種表ウィンドウが閉じられます。


３次収差係数表について

メインメニューで 「ツール」－「３次収差係数」を選択すると表のウィンドウが起動します。

SAは球面収差係数、CMはコマ収差係数、ASは 非点収差係数、DSは歪曲収差係数、PTはペツファル和を示します。Ｌは 軸上色収差、Ｔは倍率の色収差の係数です。

「Close」ボタンを押すとダイヤログが閉じられます。

ベンディング時にあらかじめ3次収差係数表を表示しておくと、表値はベンディングと連動して変化します。ベンディングウィンドウを出 す前に、3次収差係数表ウィンドウを見やすい位置に移動しておいて下さい。


DataSave

｢DataSave｣ボタンを押すと、表示されているデータがタブ区切りテキストファイルとしてセーブされます。表計算ソフト等に よる印刷に利用して下さい。


Print

３次収差係数表データをプリントアウトします。
｢Print｣ボタンを押すと、Previewウィンドウが起動します。

しかしプリントアウトには、セーブしたデータの表計算ソフトによる印刷を おすすめします。


小計の挿入

レンズ群ごとの３次収差係数を計算するのに用います。３次収差係数表上で３次収差係数の小計を表示することができます。

ウィンドウの左下にある挿入アイコンをクリックすると動作します。

小計を表示したい行の次の行にフォーカスをもっていった後にアイコンを クリックすると、その上の行までの小計が表示されます。すでに小計の表示された行があるときには、その 次の行から小計表示行の上までの小計が表示されます。

たとえば面が８面目まであるときに、No.5 の行をクリックしてフォーカスを持っていき、挿入アイコンをクリックすると、No.1～4 までの３次収差係数の小計が表示されます。

フォーカスが No.1 又は No.2 の行にあるときには、No.0 又は No.1の面までの小計を表示することは無意味ですので、アイコンをクリックしても反応しません。


小計行の削除

３次収差係数表上の小計の行を削除することができます。

ウィンドウの下にある削除アイコンをクリックすると動作します。小計行の表示位置を間違った場合などにご使用下さい。

フォーカスが小計行にないときにはアイコンをクリックしても反応しません。


収差図ウィンドウについて

メインメニューで｢ツール｣ － ｢収差図｣ の次にどれかの収差図を選択すると、収差図ウィンドウが起動します。

焦点が無い場合には警告のダイヤログが出、収差図は出ません。

下の図は縦球面収差図の例です。

ウィンドウでは、上のタブを選択することによって、縦球面収差図、横球面収差図、非点収差図、歪曲収差図、スポットダ イヤグラム、波面収差図（Line）、波面収差図（面）、波動光学 的像面図を表示できます。
非点収差図、歪曲収差図で最大入射角が設定されていない場合には、ダイヤログに０を越える適切な数値を入れて下さい。

｢スケール｣の上下ボタンを押すと、横軸のスケールがそれぞれ２倍、 1/2倍に変化します。
隣のテキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。

左上の４色のアイコンは波長選択ダイヤログ起動のショートカット、
計算機のアイコンは、再計算のためのものです。


縦球面収差ウィンドウの見方

メインメニューで｢ツール｣ － ｢収差図｣ － ｢縦球面収差図｣ を選択すると、このウィンドウが起動します。

図の横軸はｄ線の軸上光線の焦点距離位置からの距離です。単位はメインメニューのデータ表と同じで、通常はmmです。
縦軸は入射光線の入射高で、焦点距離をこの値で割って、さらに２で割った値がＦ値になります。
図中の黄色の点線は、ｄ線の正弦条件を表したものです。球面収差曲線との差がコマ収差の目安になります。

｢スケール｣の上下ボタンを押すと、横軸のスケールがそれぞれ２倍、 1/2倍に変化します。
隣のテキストボックスに数値を入れて Enter キーを押すと、入れた値が有効になります。

左上の４色のアイコンは波長選択ダイヤログ起動のショートカット、
計算機のアイコンは、再計算のためのものです。


Preview

印刷のための Previewウィンドウを起動します。

プレビューウィンドウでは、白色のところが印刷される範囲です。「Print」 ボタンでプリンターダイヤログが起動します。


Save Inifile

設定を Inifile に保存します。保存されるのは各ウィンドウのサイズや位置などです。収差図ウィンドウに関しては、背景色、波長、光線本数で、Bending 図ではその条件等です。またスポットダイヤグラム図の円等の表示や入射角表、焦点位置間隔等も保存されます。その他、OTF図の表示 最大本数、OTF図用の各波長の加重係数等も保存されます。


閉じる

図を閉じてメインメニュー画面に戻ります。


ペン太さ

ペン太さダイヤログを起動します。


背景色

収差図の背景の色は変えることができます。このメニューを選択すると色の設定ダイヤログが立ち上がりますので、希望の色を選択して下さい。
現在のところ、バグのために、波面収差（面）図を選択すると、背景色が白に戻ってしまいます。


Bending

Bendingウィンドウを起動して、ベンディング時の球面、非点、歪 曲収差曲線の変化を調べます。非点収差、歪曲収差曲線の最大入射角が指定されていない場 合には最大入射角設定ダイヤログが起動します。

Bendingウィンドウ内では初めにベンディング面の指定をして下さ い。


波長

波長選択ダイヤログを起動し、計算、表示する波長を選択します。


光線数／半径

光線数設定ダイヤログを起動し、レンズ中心からレンズ端までの計算さ れる光線数を決めます。選択可能範囲は２～40本です。デフォルトは30本です。

本数が多いほど計算に時間がかかりますが、低速のCPUでない限り瞬時に表示されるでしょう。


Help

Help を起動し、関連項目を表示します。


横球面収差ウィンドウの見方

メインメニューで｢ツール｣ － ｢収差図｣ － ｢横球面収差図｣ を選択すると、このウィンドウが起動します。
画面のショートカットアイコン等の使い方は収差図ウィンドウのページを参考 にしてください。

図は中央で左右２つに分かれています。左がメリジオナル面、右がサジタル面の図で、入射角０度の場合は左側のみ表示されます。

図の縦軸はｄ線の軸上光線の焦点距離位置での各光線までの距離です。
横軸は入射光線の入射高です。

｢スケール｣の上下ボタンを押すと、縦軸のスケールがそれぞれ２倍、 1/2倍に変化します。
隣のテキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。

左上の４色のアイコンは波長選択ダイヤログ起動のショートカット、
計算機のアイコンは、再計算のためのものです。

下の Angle の欄は、現在の入射角です。テキストボックスに数値を入れて計算機アイコンを押すと、その入射角で計算、表示がされます。
テキストボックス内には小数を入れてもかまいません。分の欄に60以上の数字を入れると、度の欄が再計算されます。
    例： 2.8ﾟ 95' → 4ﾟ 23'
上下ボタンを押すと、｢Option｣－｢入射角間隔｣で設定した角度ずつ入射角が変化します。
｢Next｣ボタンを押すと、｢Option｣－｢入射角表｣ で設定した、次の入射角が計算されます。
入射角が大きすぎるときには、結果は何も表示されません。入射角を小さくして再計算して下さい。

焦点位置のボックスの使い方はスポットダイヤグラムのときと同様です。


下記以外のメニューについて

各メニューについて

「Form」-「Preview」
「Form」-「閉じる」
「View」-「ペン太さ」
「View」-「背景色」
「Option」-「波長」
「Option」-「光線数／半径」
については、縦球面収差図の説明と同じですのでそちらを参照して下さい。


入射角間隔

入射角間隔設定ダイヤログが起動します。


入射角表

入射角表設定ダイヤログが起動します。


焦点位置間隔

焦点位置間隔設定ダイヤログを起動します。


実行

再計算、表示を行います。下の入射角テキストボックスの値を変更したときに用います。
計算機アイコンを押した場合と同じです。


中止

時間のかかる計算を中止します。横球面収差図では用いることはないでしょう。


非点収差ウィンドウの見方

メインメニューで｢ツール｣ － ｢収差図｣ － ｢非点収差図｣ を選択すると、このウィンドウが起動します。
画面のショートカットアイコン等の使い方は収差図ウィンドウのページを参考 にしてください。

最大入射角が設定されていない場合にはダイヤログが立ち上がりますので、 適切な数字を入力して下さい。

図の曲線は各色それぞれ２本に分かれています。実線がメリジオナル面、点線がサジタル面になります。
図の縦軸は入射角です。
横軸は各光線の近軸での焦点位置で、単位は通常はmmです。

｢スケール｣の上下ボタンを押すと、横軸のスケールがそれぞれ２倍、 1/2倍に変化します。
隣のテキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。

左上の４色のアイコンは波長選択ダイヤログ起動のショートカット、
計算機のアイコンは、再計算のためのものです。

下の Angle の欄は、現在の最大入射角です。テキストボックスに数値を入れて計算機アイコンを押すと、最大入射角が変化し、再計算、表示がされます。
テキストボックス内には小数を入れてもかまいません。分の欄に60以上の数字を入れると、度の欄が再計算されます。

この非点収差は主 光線付近の様子を示したものなので、実際の像とは異なる可能性があります。詳しい収差状況はスポットダイヤグラムで確認して下さい。
シュミットカメラなど焦点面が球面の場合には、その球面上での非点収差図が出ます。


各メニューについて

「Form」-「Preview」
「Form」-「閉じる」
「View」-「ペン太さ」
「View」-「背景色」
「Data｣－｢Bending｣
「Option」-「波長」
については、縦球面収差図の説明と同じですのでそちらを参照して下さい。


最大入射角

最大入射角設定ダイヤログが起動します。
計算を行いたい最大入射角度を入れて下さい。

なお、計算が行われるのは主光線がビグネッティングで切られない範囲です。


光線数／最大角

光線数設定ダイヤログを起動し、軸上光線から最大入射角までの計算さ れる光線数を決めます。選択可能範囲は２～40本です。デフォルトは30本です。


歪曲収差ウィンドウの見方

メインメニューで｢ツール｣ － ｢収差図｣ － ｢歪曲収差図｣ を選択すると、このウィンドウが起動します。
画面のショートカットアイコン等の使い方は収差図ウィンドウのページを参考 にしてください。

最大入射角が設定されていない場合には ダイヤログが立ち上がりますの で、適切な数字を入力して下さい。

図の縦軸は入射角です。
横軸は歪曲収差が無いときの主光線の位置に対する実際の主光線の位置の差をパーセントで示したものです。

｢スケール｣の上下ボタンを押すと、横軸のスケールがそれぞれ２倍、 1/2倍に変化します。
隣のテキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。

左上の４色のアイコンは波長選択ダイヤログ起動のショートカット、
計算機のアイコンは、再計算のためのものです。

下の Angle の欄は、現在の最大入射角です。テキストボックスに数値を入れて計算機アイコンを押すと、最大入射角が変化し、再計算、表示がされます。
テキストボックス内には小数を入れてもかまいません。分の欄に60以上の数字を入れると、度の欄が再計算されます。

この歪曲収差は主 光線付近の様子を示したものなので、特にコマ収差が大きい場合など、実際の像の位置とは異なる可能性があります。詳しい 収差状況はスポットダイヤグラムで確認して下さい。
シュミットカメラなど焦点面が球面の場合には、その球面上での歪曲収差図が出るはずです。


各メニューについて

「Option」-「最大入射角」
「Option」-「光線数／最大角」
については、非点収差図の説明と同じですのでそちらを参照して下さい。

また
「Form」-「Preview」
「Form」-「閉じる」
「View」-「ペン太さ」
「View」-「背景色」
「Data｣－｢Bending｣
「Option」-「波長」
については、縦球面収差図の説明と同じですのでそちらを参照して下さい。


スポットダイヤグラムの表示

メインメニューで｢ツール｣ － ｢スポットダイヤグラム｣ を選択するとスポットダイヤグラムウィンドウが起動します。
各アイコンの説明は下の図をクリックすると現れます。

起動時には焦点位置 ０、入射角 ０度での計算値が表示されますが、レンズ系構成面が多いときには表示までに多少時間がかかります。
デフォルトでは直径20マイクロメートル（データ表の値がmm単位の場合）の円が 描かれます。
中心位置は、ｄ線が描かれるときにはｄ線の各スポットの重心位置です。各収差のために、主 光線の像位置とは一致しません。


スケール

テキストボックスの数値は図の幅を示す値で、単位は通常はmmです。

上にある｢スケール｣の上下ボタンを押すと、図のスケールがそれぞれ２ 倍、1/2倍に変化します。
テキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。


焦点位置

焦点面の、ｄ線の軸上近軸光線の焦点位置からのずれを設定します。

上下ボタンを押すと、｢Option｣－｢焦点位置間隔｣で設定した距離ずつ焦点位置が変化します。－はインフォーカ ス側（レンズ側）、＋はアウトフォーカス側にずれた位置の面です。
通常、スポット径最小の位置は０から多少ずれますので、最適位置を探して下さい。

隣のテキストボックスに数値を入れて計算機アイコンをクリックする（または計算を実 行する）と、入れた値が有効になります。


Angle

下の Angle の欄は、現在の入射角です。テキストボックスに数値を入れて計算機アイコンを押すと、その入射角で計算、表示がされます。
テキストボックス内には小数を入れてもかまいません。分の欄に60以上の数字を入れると、度の欄が再計算されます。
    例： 2.8ﾟ 95' → 4ﾟ 23'
上下ボタンを押すと、｢Option｣－｢入射角間隔｣で設定した角度ず つ入射角が変化します。
｢Next｣ボタンを押すと、｢Option｣－｢入射角表｣で設定した、次の入射角が計算されます。


円描画

メニューにチェックされた状態では、「Circle radius」 で指定された大きさの円を描きます。円の中心位置はスポットの重心位置です。
デフォルトは｢円を描く」です。


円半径

円半径設定ダイヤログを起動します。
設定された円半径値は右上に、また円直径は図の左下隅に表示されます。


エアリーディスク描画

円半径設定ダイヤログを起動します。
メニューにチェックされた状態ではエアリーディスクを描きます。デフォルトは「描かない」です。


主光線位置

メニューにチェックされた状態で、主光線位置を示す十字を描きます。コマ収差が大きい場合には中心からずれた位置になります。 デフォルトは「十字を描かない」です。


Bending

Bendingウィンドウを起動して、ベンディング時のスポットダイヤ グラムの変化を調べます。
表示できる入射角は三種類までです。入射角表設定ダイヤログの上から３つ 目までの入射角が表示されます。Option－「入射角表」で設定して下さ い。

Bendingウィンドウ内では初めにベンディング面の指定をして下さい。


光線数／半径

スポットダイヤグラムの光線本数を設定します。数値は中心の次からレンズ周辺までの光線本数です。デフォルトは15です。

光線は、方眼紙の格子上の点として入射します。
光線数／半径をＳ点とすると、（Ｓ×２＋１）^2 本の光線のうち、レンズの最終面から出射できた光線が描画されることになります。
たとえば、単レンズでＳ＝３のときには各色それぞれ29本、Ｓ＝５のときには各色81本の光線が計算、描画されます。


MTF 計算

このメニューを選択するとメニューにチェックがつき、計算実行時に幾何光学的 MTF を同時に計算するようになります。計算後には左すみの「MTF 表示」が実行可能になり、このボタンを押すと、MTF ウィンドウが起動します。

幾何光学的 MTF 図はおまけの機能です。波動光学的 MTF の計算に時間がかかるような場合に簡易計算として用いて下さい。収差の少ない光学系では、計算結果がかなり実際のものと異なりますので、用いないで下さ い。


実行

再計算、表示を行います。下の焦点位置テキストボックス、入射角テキストボックスの値を変更したときに用います。
計算機アイコンを押した場合と同じです。

計算に時間がかかりすぎるときには、｢中止｣ で計算を中止した後に 「Option」-「ステップ」 及び 「Option」-「波長」で、計算本数を減らしてから再実行して下さい。


中止

時間のかかる計算を中止します。スポットダイヤグラムの表示は消えます。
｢中止｣ は ｢実行｣ を押した場合など、計算中に選択可能になります。


波面収差（Line）図ウィンドウの見方

メインメニューで｢ツール｣ － ｢波面収差（Line）｣ を選択するとこのウィンドウが起動します。
メニューの内容や画面のショートカットアイコン等の使い方は スポットダイヤグ ラムの表示のページ等を参考にして下さい。

この図は、各光線の焦点位置での主 光線に対する光路長の差を示したものです。
図の縦軸は光路長の差を選択した波長（デフォルトでは d 線の波長）を単位として示したものです。
｢スケール｣の上下ボタンを押すと、縦軸のスケールがそれぞれ２倍、 1/2倍に変化します。
隣のテキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。

横軸は入射光線の入射高です。
図は中央で左右２つに分かれています。左がメリジオナル面、右がサジタル面の図で、入射角０度の場合は左側のみ表示されます。

計算される波長は、長選択ダイヤログを出してラジオボタンで選択すること ができます。デフォルトでは d 線です。

下の Angle の欄は、現在の入射角です。テキストボックスに数値を入れて計算機アイコンを押すと、その入射角で計算、表示がされます。
上下ボタンを押すと、｢Option｣－｢入射角間隔｣で設定した角度ずつ入射角が変化します。

光路長は光軸方向の焦点位置や焦点面上の左右の位置でも変わります。光軸方向の焦点位置を変化させるにはスポットダイヤグラムの焦点位置の項と同様に行って下さい。焦点面上の位置を変えるには、右の y 方向または下の z 方向のスクロールバーを動かして下さい。基準位置（0mm）は主光線の位置です。


各メニューについて

各メニューの使い方については横球面収差図のものとほぼ同じですの で、そちらを参考にして下さい。


波面収差（面）図ウィンドウの見方

メインメニューで｢ツール｣ － ｢波面収差（面）｣ を選択するとこのウィンドウが起動します。
メニューの内容や画面のショートカットアイコン等の使い方はスポットダイヤグラム の表示のページ等を参考にして下さい。

この図は、各光線の焦点位置での主 光線に対する光路長の差を選択した波長（デフォルトでは d 線の波長）を単位として示したものです。
計算される波長は、波長選択ダイヤログを出してラジオボタンで選択するこ とができます。デフォルトでは d 線です。

図の円は入射瞳を示しています。灰色は主光線との光路長の差がないことを示しており、白または黒は｢スケール｣で示された波長分だけずれていることを示しています。
スケールの値が 1 の場合には、真っ白な部分は 1 波長以上長く、真っ黒な部分は 1 波長以上短いことになります。詳しいズレ量は、波面収差（Line）図を見て 下さい。
色がついていない部分は光線が途中でさえぎられている部分です。この図で周辺光量も見当がつきます。周囲がぎざぎざしていますが、気 にしないで下さい。ぎざぎざのステップを小さくするには、光線数／半径を 多くして下さい。あまり多くすると計算時間が長くなります。

下の Angle の欄は、現在の入射角です。上下ボタンを押すと、｢Option｣－｢入射角間 隔｣で設定した角度ずつ入射角が変化します。

左下にはRMS値とその値から計算されるストレール比が示されます。これらの値は計算した一波長のみのものです。その下にある 「RMS Cal」のボタンを押すと、各波長でのストレール比及び白色光 のストレール比を示すウィンドウが起動します。

光路長は光軸（x）方向の焦点位置や焦点面上 yz 方向の位置でも変わります。光軸方向の焦点位置を変化させるにはスポットダイヤグラムの焦点位置の項と同様に行って下さい。
焦点面上の位置を変えるには、右の y 方向または下の z 方向のスクロールバーを動かして下さい。基準位置（0mm）は主光線の位置です。位置を変えるとRMS値やストレール比の値は変わります。


ストレール比の計算

波面収差（面）図ウィンドウで左下の「RMS Cal」のボタンを押すと、ス トレール比のウィンドウが起動します。
ストレール比の値は、RMSの計算値から、exp(-(2*pi*RMS)^2) の式で計算されます。

ストレール比ウィンドウ内では、MTFの計算と共通の各波長の重みをつけ た、白色光のストレール比が黒色で表示されます。

またストレール比ウィンドウ内で入射角や焦点位置の変化によるストレール比の変化も計算できます。


各メニューについて

各メニューの使い方についてはスポットダイヤグラムのものとほぼ同じで すの で、そちらを参考にして下さい。


波動光学的像面図ウィンドウの見方

収差図ウィンドウで ｢波動光学的像面｣ のタブを選択すると、まず入射瞳分割数設定ダイヤログが起動します。その ダイヤログで [Execute] または [OK] を押すと波動光学的像面図になります。
[OK] を押した場合には、 計算機アイコンを押して計算・表示を行って下さい。

なお、計算・表示には時間がかかります。左上の「しばらくお待ち下さ い」の表示が消えるまでお待ち下さい。
途中で計算を中止する場合には、メニューの［計算］中の［中止］を選んで下さい。
「計算」「中止」のメニューは選択してもすぐに反応しないことがありますが、しばらくお待ち下さい。

各アイコン等の説明は下の図をクリックすると現れます。

結果の合成色は、選択した波長およびその色によって決まります。デフォルトでは少し赤すぎるかもしれません。その場合には波長選択ダイヤログで表示色を変更して下さい。

格子模様のアイコンを押すと、「入射瞳分割数」ダイヤログが出て、再設定 できます。

印刷のためのプレビューは対応していないので印刷はできません。画面コピーを使用して下さい


スケール

テキストボックスの数値は図の幅を示す値で、単位は通常はmmです。

｢スケール｣の上下ボタンを押すと、図のスケールがそれぞれ２倍、1/2倍に変化します。テキストボックスに数値を入れて [Enter] キーを押すと、入れた値が有効になります。
本プログラムでは表示領域の情報をメモリに保存して表示しており、表示速度の高速化及びメモリの節約のために、FFT の計算結果は「スケール」プラスアルファの範囲のみ保存されています。このため上のボタンを押して表示範囲を広げたときに周囲に未計算の白い部分が現れる ことがあります。
広い範囲を見るためには、先にスケールを大きくして拡大率を下げてから再計算して下さい。それでも周囲が表示されない場合には、入射瞳分割数ダイヤログでFFTサイズを大きくして下さい。


FFT サイズと入射瞳分割数

二次元 FFT のサイズ A×A は 2^n×2^n である必要があり、本プログラムでもそのようになっています。入射瞳分割数 B×B はそのような制限はありませんが、多くとも FFT サイズの半分以下、B < 1/2 A である必要があります。
計算できる像面の広さは入射瞳分割数 B に比例し、像面の分解能は A/B によってきまります。また同じ分解能でも、FFT サイズ A が小さいと、正しくないゆらぎが見えてきます。FFT サイズは 512×512 以上は必要でしょう。

入射瞳分割数 B は 64 以上、A/B は ４ 以上ほしいところですが、A のサイズによって計算時間は大きく変わります。
必要メモリも FFT サイズによって大きく変わり、A=2048 のときには FFT にかける行列だけで、2k×2k×8バイト×2（複素数）= 64MB 必要です。その他計算途中には光線追跡のための行列や変数を一時的に収納する行列など、この 1.5 倍程度のメモリを必要とします。A が２倍になると、必要メモリは４倍になります。
この他に、計算できる像面の広さを広く取って計算すると、かなり多くのメモリを必要とします。

コンピュータの搭載メモリ及び HDD の論理メモリの大きさにもよりますが、一般に 2048×2048 以上の計算をする場合には、他のアプリケーションを終了してメモリを開放し、本プログラム終了後には Windows の再起動を行うのが無難です。


下記以外のメニューについて

各メニューの使い方についてはスポットダイヤグラムのものとほぼ同じです ので、そちらを参考にして下さい。


Linear <-> Root, Log

像面図の二次元表示は、
・明るさの値をそのまま
・明るさの値を平方根に直して表示
・明るさの値を対数値に直して表示
の3種類できます。デフォルトは平方根の値で、Linear <-> Root のメニューにチェックがつきます。またルート（√）のアイコンは押された状態になります。明るい部分から暗い部分まできれいに表示されます。
メニューで Linear <-> Log を選択するか「log」 のアイコンを押すと、Linear <-> Log にチェックがつき、「log」 のアイコンが押された状態になって、対数値表示になります。

チェックのついたメニューをもう一度選択するか、又は押されているアイコンをもう一度押すと、どちらのアイコンも押されていない状態 になり、明るさの値そのまま（Linear）での表示になります。暗い部分は見えにくくなります。


像強度曲線

像面図に同時に点像強度分布曲線を重ね書きします。
二次元分布の表示法とは関係なく、リニアスケールで表示されます。像面輝 度を変えると強度のスケールが同時に変化します。スケールは左端に表示されます。

軸上光線では一本のみですが、軸外光線や斜鏡がある場合にはメリジオナル面とサジタル面について曲線が表示されます。メリジオナル面 は図の右側に表示されます。

表示されるのは白色光に対する値です。各波長の重みは MTF図ウィンドウの 「Spectrum」のボタンを押して出る感度曲線によって決まります。
ある波長のみについての値を求める場合には、波長選択ダイヤログでその波 長のみを選択しておいて下さい。

計算されるのは図の中心を通る線上です。別の位置の強度分布を表示したい場合には、右又は下のス クロールバーを操作して、計算したいところを中心にもってきて下さい。

なお、何かの拍子に曲線表示が消えることがあります。原因はまだわかっていないのですが、応急処置として、このような場合には左下す みに「再描画」のボタンが現われますので、これを押して曲線を再描画して下さい。


MTF計算

このメニューを選択するか、又はMTF 表示アイコンを押すと、メニューにチェックがつき、計算実行時に波動光学的 MTF を同時に計算するようになります。計算後には左すみの「MTF 表示」が実行可能になり、このボタンを押すと、MTF ウィンドウが起動します。

MTF 計算を選択すると、さらにメモリ使用量が増加します。


Bendingウィンドウについて

このウィンドウではベンディングだけでなく１面のみの曲率変化又は面間隔変化による収差図の変化を調べることができます。１面のみの変化を調べるときには 上のタブ「１面のみ変化」をクリックしてください。

表の上でベンディングを行いたい２面を指定し、下のスクロールバーを操作してベンディングを行います。左の図に上から縦球面収 差図、非点収差図、歪曲収差図が表示されます。
１面のみ変化の場合は変化させる面、面間隔の場合には右にスクロールして該当する「distance」をダブルクリックしてくださ い。
データを固定してある場合には、そのデータは指定できません。

図の左にある上下ボタンを押すと、横軸が拡大縮小します。

ベンディングを行う面を変更する場合にはまず ｢選択解除｣ で面の指定を解除し、改めて面を指定し直します。

「Undo」ボタンを押すと最後のベンディング操作の前に戻ります。

ベンディング後は焦点距離が変わるので、もとの焦点距離に戻すには ｢焦点距離調 節｣ ボタンを押します。

「OK」でベンディング結果が反映され、「Cancel」ではすべて破棄されてウィンドウが閉じます。


スポットダイヤグラムの表示

スポットダイヤグラム図からベンディングを選んだときには、Bendingウィンドウ内にスポットダイヤグラムが３つまで表示されます。表示されるのは、 入射角表設定ダイヤログの上から３つ目までの入射角です。
スポットダイヤグラムの場合には、計算に時間がかかるために、スクロールバーを動かしても表示は連続して変化せず、表示はマウスボタ ンを離したときのみです。さらにマウスのボタンを押しつづけても無視されます。つまみを動かした場合には表示が変化するのはつまみを 放したときです。連続した変化を見る場合にはマウスのクリックを繰り返して下さい。

左の「focus」の下の上下ボタンを押すと、スポットダイヤグラムウィンドウでの「焦 点位置間隔」で設定した値ずつ焦点位置が変わります。
その下の左右ボタンを押すと、スケールが２倍／1/2倍ずつ変化します。

時々これらの{\uldb ボタンの反応が悪い}{\v HLP000258}ことがあります。


ベンディング面の指定

「ベンディング（２面）」の場合にはベンディングの面は２面指定します。
Bendingウィンドウのデータ表の上でベンディングを行う面をそれぞれダブルクリックで選択すると色が変わり、２面指定されると ベンディング指定のスクロールバーが操作できるようになります。
指定の解除は ｢選択解除」 ボタンで行います。


Bending スクロールバー

ベンディングを行うにはベンディング面の指定を行う必要があります。

スクロールバーが操作できる状態になったら、スクロールバー左右の矢印又はスクロールボックスとスクロール矢印の間をクリックする か、スクロールボックスのつまみを移動させることによってベンディングが行われます。値を大きく変化させる場合にはボックスのつまみ をクリックしてドラッグしてください。少し荒めに変化させるときはつまみと矢印の間、細かく変化させるときには左右の矢印をクリック して下さい。

スクロールボックスの移動の場合では、マウスをドラッグ後に離すと、何故かさらに収差曲線が動いてしまいます。クリックで戻してくだ さい。


Interval

一回の矢印のクリックで変化するレンズパワーの値は、Interval のテキストボックス内の値が適用されます。
上下ボタンを押すと、Interval の値が２倍又は1/2倍（ただし小数２桁目は切り捨て）になります。

始めに大まかにベンディングを行うときには大きめ、仕上げに細かくベンディングで修正するときには小さめの数値を入れて下さい。


選択解除

ベンディング面の指定をクリアします。ベンディングのためには再びダブルクリックで面の指定をやり直して下さい。


焦点距離調節

ベンディングを行うと焦点距離が変化しますが、このボタンをクリックすると元の焦点距離になるように各曲率及び面間隔が変化しま す。固定してある曲率又は面間隔は変化しません。固定データがあると、収差状況が少し変化します。
メインメニューで｢ツール｣－｢焦点距離｣を選択し元の焦点距離を入れて｢OK｣を押したのと同じような状 態になります。

面間隔を変化させたくない場合などでは、メイン画面であらかじめ固 定しておいて下さい。


OK、Cancel

｢OK｣で結果を保持してウィンドウを閉じます。

｢Cancel｣ボタンをクリックすると、ベンディングの結果を破棄してウィンドウを閉じます。データはベンディング前と同じになり ます。


MTF図ウィンドウについて

スポットダイヤグラム又は波動光学的像面図で MTF 表示ボタンを押すと、この図が現われます。スポットダイヤグラムからは幾何光学的 MTF、波動光学的像面図からは波動光学的 MTF が表示されます。

はじめに出てくる図は横軸が空間周波数、縦軸が MTF の値です。
収差図ウィンドウ中の波長選択ダイヤログで選択した波長についての MTF の値がそれぞれの色で表示され、各波長の重みを掛けた白色光 MTF が黒線で表示されます。
斜入射光に対しては、メリジオナル面の値が実線で、サジタル面の値が点線で表示されます。

各波長の重みについては、上の「Spectrum」のボタンを押して値を調 節することによって変えることができます。

上のタブはデフォルトで「空間周波数」となっており、横軸最大値は、デフォルトでは理想光学系で最短波長の MTF が 0 になる空間周波数です。幾何光学的 MTF の場合には、あまり大きな数字は意味がないので、最大 200 本／mm にしています。
横軸の値は、グラフの横軸よりも下の部分をクリックするか下の「Scale」ボタンを押して、最大表示空間周波数のウィンドウに希望 値を入力することによって値を変えることができます。

タブの選択によって、「入射角」で、カメラ雑誌でよく見かけるような入射角に 対するある空間周波数での MTF、「焦点位置」で最適焦点位置の計算が できます。

波動光学的 MTF では、上の「MTF」のアイコンが押された状態では MTF の値が、「OTF'」のアイコンを押すと MTF×cos(PTF) で表される OTF の実軸成分が表示されます。OTF' では白色光の値は表示していません。

右上の「Save」のボタンを押すと MTF 値をテキストデータとして保存できます。

なお、この MTF 図ウィンドウを閉じないと、収差図ウィンドウやメインメニュー等は操作できません。


各波長の重み

MTF図ウィンドウで「Spectrum」のボタンを押すと出てき ます。

この図は選択された各波長に対する MTF 及び 像面強度曲線への重みを示します。
横軸の下は各波長、横軸のすぐ上の数字がそれぞれの重みの値です。
横軸の値は「Scale」をクリックすることにより変えることができま す。

重みの値はこの感度曲線を変化させることによって変えることができます。眼視、銀塩、CCD など目的に応じて感度曲線を作成してください。

感度曲線は、各波長の上の線上にある○印をクリックしてドラッグすることにより、変化させることができます。「OK」ボタンで変更が 有効になり、「Cancel」ボタンでは変更は無視されて、元の MTF 図に戻ります。
感度曲線を保存する場合には、収差図ウィンドウ上で「Save Inifile」 を行って下さい。


入射角

MTF図ウィンドウ上のタブの選択によって、カメラ雑誌でよく見かけるような入射角に対するある空間周波数値での MTF の値を表示することができます。

タブを選択すると、はじめに表示する空間周波数値を尋ねてきますので、表示させたい値をを入力して下さい。表示できる値は、次の MTF 空間周波数記録最大値によって決まりますが、デフォルトでは２の倍数で 200 本／mmまでです。これ以外の数値では、一番近い値がまた表示色の選択ができ、色の欄をダブルクリックすると色の設定ダイヤログが立ち上がります。
次に、MTF 空間周波数記録最大値を決めますが、特に問題なければデフォルトのままにしておいて下さい。この数値を 100 等分した値ごとに白色光 MTF が計算され、データの保存にも使用されます。

次に角度指定ダイヤログが出てきますので、計算したい入射角を入れて下さい。この表は、入射角表設定ダイヤログとほぼ同じですが、表中をダブルクリックすると等間 隔の角度指定が容易にできます。
ダブルクリックによって、最大入射角ダイヤログと入射角計算間隔ダイヤログが出てきますので、適切な値を入れて下さい。「OK」を押 すと指定した間隔で表に数値が入りますので、良ければ「OK」で確定してください。
「OK」によって計算が始まり、結果は横軸が入射角、縦軸が指定した空間周波数でのコントラスト値です。なお「キャンセル」を押す と、計算は行われません。
画面上で任意の位置をダブルクリックすると、入射角指定ダイヤログがでてきて、その位置に一番近い値が入っていますので、良ければ 「OK」を押して下さい。以降の計算は その入射角で行われます。

入射角の計算数は２以上として下さい。入射角が一つだけの場合には指定された入射角で計算されますが表示はされません。
なお、計算数だけ時間がかかりますので、あまりに多くの角度数を指定しないで下さい。波動光学的像面から計算する場合には、FFT サイズは 512 以下をお勧めします。

計算条件を変えるのは、「再設定」ボタンを押すことによってできます。ま た Save ボタンによって計算値をファイルに保存できます。


焦点位置

MTF図ウィンドウ上のタブの選択によって、デフォーカス量の変化による MTF 値を計算でき、最適焦点位置を見積もることができます。

タブを選択すると、はじめに表示する空間周波数値を尋ねてきますので、表示させたい値を入力して下さい。表示できる値は、次の MTF 空間周波数記録最大値によって決まりますが、デフォルトでは２の倍数で 200 本／mmまでです。これ以外の数値では、一番近い値がまた表示色の選択ができ、色の欄をダブルクリックすると色の設定ダイヤログが立ち上がります。
次に、MTF 空間周波数記録最大値を決めますが、特に問題なければデフォルトのままにしておいて下さい。この数値を 100 等分した値ごとに白色光 MTF が計算され、データの保存にも使用されます。

焦点計算開始位置と焦点計算間隔、焦点計算数によって、デフォーカス量及び計算する像面数を指定します。各ダイヤログに適切な数値を 入れて下さい。

各ダイヤログで「OK」を押すと計算が始まります。結果は横軸が焦点位置（デフォーカス量）、縦軸が指定した空間周波数でのコントラ スト値です。各空間周波数で一番コントラストの高いところがベストフォーカス位置になります。画面上でその位置をダブルクリックする と焦点位置決定ダイヤログが でてきますので、良ければ「OK」を押して下さい。
焦点位置を決定すると、以降の計算はその位置で行われます。

焦点計算数には２以上の数値を入れて下さい。計算数１の場合には指定された焦点計算開始位置で計算されますが表示はされません。ま た、各ダイヤログで「キャンセル」を押すと、計算は行われません。
なお、計算数だけ時間がかかりますので、あまりに多くの焦点計算数を指定しないで下さい。波動光学的像面から計算する場合には、FFT サイズは 512 以下をお勧めします。

計算条件を変えるのは、「再設定」ボタンを押すことによってできます。ま た Save ボタンによって計算値をファイルに保存できます。


条件の再設定

MTF図ウィンドウ上のタブの選択で「入射角」又は「焦点位置}」を選んで表示している場合に、入射角値又はデフォーカス値等の 条件を変えて再計算したい場合に用います。
ボタンを押すと、タブを選択した場合と同じダイヤログが再び現われますので、希望の数値を入れて下さい。

なお、表示したい空間周波数値のみを変更したい場合には再計算の必要はなく、タブで一度「空間周波数」を選んでから再び「入 射角」又は「焦点位置}」を選んで下さい。表示する空間周波 数選択のダイヤログが出てきます。


Save

MTF図ウィンドウ上の右上の「Save」のボタンを押すことによって MTF 値をタブ区切りテキストデータとして保存することができます。

保存されるデータはメリジオナル面及びサジタル面の白色光 MTF の値です。
空間周波数の表示最大値を 100 等分した各空間周波数値に対するコントラスト値が記録されます。
横軸が空間周波数の場合には、横軸の右端の値が空間周波数表示最大値です。

タブで「入射角」を選択して横軸を入射角にしている場合には各入射角での値、 「焦点位置」を選択して横軸がデフォーカス量の場合には各デフォーカス値 でのそれぞれの MTF の値が記録されます。


計算条件変更後

「入射角」又は「焦点 位置}」で図上でダブルクリックして入射角値や焦点位置を変更した後にタブで「空間周波数」を選んで戻ると、各色の MTF は表示されず、白色光 MTF のみが表示されます。

また、MTF図ウィンドウ終了後のスポットダイヤグラム図又は波動光学的像面図は、変更した入射角や焦点位置にはなっていませんので、再 計算用の計算機アイコンを押して図を更新してください。


レンズ断面図ウィンドウについて

メインメニューで｢ツール｣ － ｢レンズ断面図｣ を選択すると、このウィンドウが起動します。

レンズ系はメイン画面の表のデータのものです。光線数は ｢入射光線｣ － ｢入射光線数｣ で光線数選択ダイヤログを起動して設定できます。

レンズデータのうち、面の前後で屈折率がどちらも１の場合には、絞りと見なし、図上では有効径の外側に引かれた線として表示されま す。


Preview

印刷のための Previewウィンドウを起動します。


Save Inifile

各ウィンドウ上の設定を Inifile に保存します。レンズ断面図ウィンドウについては、保存されるのはサイズや位置以外には入射角表、入射光線数等です。


Close

レンズ断面図ウィンドウを閉じて、メインメニュー画面に戻ります。


入射角表

入射角表ダイヤログが立ち上がります。このダイヤログ内では、入射角設定ダイ ヤログに加えて光線の色指定が可能になっており、複数の入射角の光線を色別に表示することができます。

レンズ断面図ははじめは入射角０度の光線だけが表示されています。


入射光線数

光線数選択ダイヤログが立ち上がります。
一つの入射角に対して何本の光線を表示するか選択できます。デフォルトは７本です。最大100本ですが、あまり多いと見にくくなりま す。


拡大、全体

｢表示｣－｢拡大｣ を選択すると、カーソルが白の画面上で十字カーソルに変化します。
拡大したい領域の中央でマウスをクリックし、そのままドラッグすると画 面に破線で範囲が示されます。マウスボタンを離し、そのまま動かさずにもう一度クリックすると、破線の範囲が拡大された図が表示され ます。破線の範囲が確定してから二度目のクリックの前にマウスを動かすと、範囲はキャンセルされます。
｢拡大｣は何度でも選択できますが、拡大しすぎた場合に一段階だけ戻ることはできません。

｢表示｣－｢全体｣ を選択した場合には、始めに表示された全体の断面図が現れます。


All Ray

デフォルトでは、レンズの縁からはみ出した光線、中央遮蔽物にかかった光線などは表示されませんが、｢All Ray｣ではこれらを表示するようにします。

｢All Ray｣を選択したのちは表示が｢Real Ray｣に変わ ります。｢Real Ray｣を選択すると、元の表示に戻ります。


光線表示位置

光線表示位置ダイヤログを起動します。
デフォルトでは表示される光線は近軸光線の焦点位置までです。球面収差の多い光学系では一部の光線が焦点前で切れてしまっています。
それよりも先まで光線を表示させたいときには、この光線表示位置を選択し、ダイヤログ中に近軸光線の焦点からどれぐらい先まで表示す るかを入力して下さい。5～20mm程度が適当でしょう。

光線表示位置ダイヤログ中にあまりに長い距離を入力した場合には、警告のダイヤログが出ます。


MultiColor

光路図として波長選択ダイヤログで選択されている波長すべてを表示す るようにします。
表示色は波長選択ダイヤログで表示されている色です。表示色の角度別の選択色は無視されます。

->MultiColor を一度選択すると、表示は->SingleColorに変わり、これを選択すると元の表示に戻ります。


WaveLength

計算する波長をラジオボタンで選択します。デフォルトは単一波長では d 線です。

MultiColor を選択しているときには、チェックボックスで計算波長が選択できます。


ペン太さ

ペン太さダイヤログを起動します。
レンズの断面の線及び光線の太さを変化させます。ダイヤログの中の数値を変えて｢OK｣ ボタンを押すと、数値が適用されます。
この数値はレンズ断面の線の太さです。光線の太さはこの値よりも少し細くなります。
デフォルトは１です。１～５の値が選択できます。印刷には２程度が良いでしょう。


最適化について

－最適化－
自動設計とも言いますが、本プログラムではほとんど無から完成品ができるわけでもないし、できることはせいぜいデータの最適化程度で す。
本ソフトでは、幾何光学的光線追跡による焦点位置、又は波面収差から計算されるストレール比の値から、最適化が可能です。

最適化ではローカルミニマム（局所的な極小値）に陥りやすいので、
・あらかじめベンディング等で収差の少ない条件を見つける
・何度も最適化を繰り返す
    （初期値が擬似乱数で設定されるのでローカルミニマムを越える可能性あり）
・最適化後にもう一度ベンディングを試みる
などの工夫が必要です。

最適化の際に変化させたくないパラメータ（レンズの厚さ等）は、あらかじめメイン画面のデータ表上で {\cf2 Fix} にチェックを入れて下さい。

実行のためにはあらかじめ条件設定ダイヤログで各重みの設定をして下さ い。


条件設定ダイヤログ

自動修正のときの評価関数の重みを決めます。

上の枠内のラジオボタンで、最適化の計算に幾何光学的光線追跡を用いるか波動光学的なストレール比を用いるかを選択します。デフォル トは幾何光学的です。
ストレール比は、波面収差からRMS値を求めて計算しており、かなり時間がかかります。またストレール比は選択した波長に重みを掛け た 白色光のストレール比です。

左側は、各波長の重みです。紫側を重視しない場合は、ｇ線、ｈ線の数値を小さくして下さい。重視する波長が１、それ以外は１未満で良 いと思います。
色収差の多い光学系では選択波長の収差が小さくなるように最適化されますので、実際のものと異なる結果になることがあります。そのよ うな場合には、計算波長を増やして下さい。ただし計算時間は波長数に比例 します。

まんなかは、いろいろな条件の重みです。特に重視したい項目は、２とか３とかを入れて下さい。
Angle は右の入射角表の重みです。
Spherical Aber は３次収差係数のうち球面収差係数の重みです。
Coma は球面収差図でのｄ線の球面収差曲線と正弦条件の曲線との差の重みです。
Petzval Sum は像面平坦性の目安となるペツファル和の重みです。
Astigmat は非点収差係数の重みです。
Distortion は歪曲収差係数の重みです。
Lens Curvature はレンズ有効径／曲率半径の和の重みです。この和の値が大きいほどレンズの製作が困難になります。深い曲面を避けたいときには、重みの数値として１などを 入れてください。

右側は入射角ごとのスポットダイヤグラム上の散らばりの許容量です。
左の列に入射角（度）、右の列に許容量（メインメニューのデータ表単位がmmのときにはマイクロメートル）を入れて下さい。
また「ストレール比」を選んだ場合には、入射角ごとの目標ストレール比値になります。

この重みの付け方によって、最適化の結果、収束速度などが変わります。いろいろ試してみて下さい。

左下の「焦点距離固定」は、チェックを外した場合、データ変化による焦 点距離の変化を補正しないようになります。固定データの多い場合などに用いて下さい。デ フォルトではチェックされており、焦点距離は常に一定に保たれています。変化できるデータが１つだけのときにはチェックは外れます。


入射角に対する重みについて

スポットダイヤグラムの中心位置は散らばりの重心になります。中心からある点までの距離をｒ、許容量をＴとすると、この点の評価値Ｖは
    Ｖ＝（ｒ/Ｔ）^2　　（ｒ<Ｔ）
      ＝２×（ｒ/Ｔ）-1　（ｒ>Ｔ）
としています。全点の和（に各波長の重みを掛けたもの）が評価の対象になっています。焦点位置としては、この和が一番小さくなる点が 取られています。

中心像をシャープにしたいときには、入射角０度のときの許容量を他より小さく取って下さい。
またコントラスト重視のときは各入射角で、 Ｔ を大きめに、解像度重視のときは Ｔ を小さめにとれば良いのではないでしょうか？


最適化表示ウィンドウについて

下に、評価値、現在までの評価値の最小値が表示されます。この値が小さくなると、最適化が進んでいます。

途中経過の表示には｢Graphics On｣ボタンを押して下さい。


Graphics On

｢Graphics On｣ボタンを押すと、ウィンドウ内に途中経過 の様子が表示され、ボタンは｢Graphics Off｣に変わりま す。
｢Graphics Off｣ボタンを押すと、ウィンドウ内の図が更新されなくなり、計算が少しだけ速くなります。


Stop

最適化計算を中断し、現在の最適値のデータを返してウィンドウを閉じます。


Previewウィンドウについて

３次収差係数、収差図、スポットダイヤグラム、レンズ断面図については、Previewを選択するとこのウィンドウが起動します。

白い部分はプリンタの描画範囲です。


印刷範囲の変更

画面をダブルクリックすると、周囲に点線が現れます。点線のところへマウスカーソルをもっていくと上下又は左右矢印が現れますの で、クリックしてドラッグすると、描画サイズが変更されます。
ただし図は相似形で、上下左右の比は変更できません。

下の｢Size｣ボタンを押しても範囲の変更ができます。


Size

数値の入力で印刷範囲を設定します。
左端、横幅、上端、高さを入力します。デフォルトはプリンタの印刷可能範囲です。
印刷可能範囲を超えて設定した場合には、自動的に可能範囲まで縮小されます。
たとえば左端に０mmを入力すると、プリンタの印刷に必要なマージンの値が設定されます。


Print

プリンターダイヤログを起動し、Previewウィンドウを閉じます。


キャンセル

何もせずにPreviewウィンドウを閉じます。


ストレール比ウィンドウについて

波面収差（面）図ウィンドウで左下の「RMS Cal」のボタンを押すと、このウィンドウが起動します。
起動時には左端に それぞれの波長の表示色で各波長のストレール比の値 が表示されます。また各波長の重みから計算された白色光のストレール比の値が黒色で表示されます。

ストレール比の値は、RMSの計算値から、exp(-(2*pi*RMS)^2) の式で計算されます。

上のタブで「入射角」を選択すると、入射角選択ダイヤログが起動しますので、計算したい入射角の値を入力して下さい。「OK」ボタン を押すと、しばらく待たされた後に計算結果が表示されます。入射角を変更する場合には「再設定」ボタンを押して下さい。
入射角が０度でない場合や非対称光学系では、焦点面上でストレール比が最大になる位置は主光線上からずれていますが、最大値になる位 置を自動的に探すようになっています。

また上のタブで「焦点位置」を選択すると、計算する焦点位置の開始位置と計算間隔、計算数を入力するダイヤログがそれぞれ起動します ので、計算したい値を入力して下さい。しばらく待たされた後に計算結果が表示されます。計算する焦点位置として、負の値ももちろん入 力可能です。

「入射角」又は「焦点位置」依存性を見ているときに、それぞれ異なる焦点位置又は入射角での値を見たい場合には、波面収差（面）図上 で焦点位置又はAngleの値を変えてから「再設定」ボタンを押して下さい。

折れ線グラフをなめらかにするには、計算する入射角数又は焦点数を増やす必要がありますが、あまり多くすると計算時間がかなりかかり ます。

上の「Spectrum」ボタンを押すと、各波長の重みを示す図が出てきますが、この重みの値はMTFの計算に使用されるものと共通です。重みの値を変更すると、MTFの計算に おいても白色光MTF値の計算が同様に変更されます。
色収差の多い光学系ではデフォルトの波長のみでは正確ではありません。中間波長を追加して密な間隔で計算して下さい。


図の表示結果がおかしいようだ

レンズ断面図、収差曲線の図の縮尺や表示内容がおかしい

→一度ウィンドウを閉じて、もう一度ツールメニューから開いてみて下さい。

・おかしな表示が再現される場合
  レンズ系最終面の距離の欄（焦点面までの距離）にバックフォーカスの値と 大きく異なる値が入っている場合にはこのようになることがあります。図のウィンドウを閉じ、距離の欄を空欄にして、もう一度図を表示 させてみて下さい。

表示がまだおかしいときにはデータをセーブしてプログラムを終了して下さい。


データ表に数値の入力ができない

・屈折率のところに違う数値を入れたいが、反応しません
  → 屈折率の値は自由には変更できません。ガラスの場合、いちばん右の備考の欄を空欄に（スペースもすべて消 去）すると、変更できるようになります。Air または Mirror の場合には、硝種の Air または Mirror を消去して下さい。

・１面目（No.0 の面）の曲率やガラスを変えたいが、入力できません
  → １面目は空気面に固定です。有効径のみ入力して下さい。

・編集メニューをいじっていたら、データ数値の変更ができなくなりました
  → 切り取りやコピーのために複数セルの選択が可能になっているときには、数値の編集はできません。（表部品の仕様なので仕方ありません）　編集－セルの編 集・選択－セル内容の編集　を選択して編集可能に戻して下さい。

・行全体が選択されていて、各セルの数値が変更できません
  → シフトやティルト面の指定になっているとこのようになります。ダ ブルクリックおよびその後のダイヤログボックスのキャンセルで抜けるか、断面図の表示など他の メニューを選択して閉じると、もとの状態に戻ります。


焦点距離が希望の値に変更されない

焦点距離設定ダイヤログを立ち上げて焦点距離値にある値を入れると、OK ボタンを押しても焦点距離がその値になりません。

  → データを Fix していませんか？
焦点距離変更では Fix していないデータ値を比例で拡大縮小しているため、Fix したデータが多すぎたりある特定の値を Fix した場合には、焦点距離を変更できる範囲は限られています。


計算の途中でプログラムが動かなくなった

計算が無限ループとか大変時間のかかるループに入った可能性が大です。
どうしようもないときには [Ctrl] - [Alt] - [Del] で強制終了を選択するしかないようです。
プログラムのバグのせいで、とんでもない数値のデータを計算させたりすると起こるようです。

他のアプリケーションが動作可能な場合にはおそらく無限ループ、まったく固まったときには不正なメモリ番地の指定が原因として考えら れます。具体的なデータがあれば検証できますので{\uldb バグ報告}{\v HLP000210}を是非お送り下さい。


レンズ断面図を拡大したら動かなくなった

固まったように見えても、しばらく待ってみて下さい。
反射面を含むレンズをむやみに強拡大すると、描画に非常に時間のかかることがあります。拡大率を適当にして下さい。


レンズ系を挿入したいが・・

現在のレンズ系の途中または後ろに、ファイルからレデューサ系などを呼び込んで入れたいのですが？

→ レンズ系の挿入は未実装です。
  表計算ソフトなどを用いて、タブ区切りデータとしてそれぞれのファイルを読み込んで、行の挿入およびカットアンドペーストなどで データを作成して下さい。


不正な浮動小数点数演算命令

スポットダイヤグラム計算中に、「不正な浮動小数点数演算命令」が出てプログラムが止まってしまうことがあります。状況が再現せず 原因不明ですが、動かないときには再計算のための 計算機アイコン をクリックしてみて下さい。


Bending画面でのボタンのクリックがひっかかる

Bending画面でスポットダイヤグラムを表示しているとき、フォーカスや拡大率変更の上下ボタンを押すとボタンが淡色表示にな り、次に押したボタンが無効になります。

  → 原因がよくわかりませんがときどきこのような現象が起こります。もう一度マウスをクリックして下さい。気になると思いますが気にしないで下さい。


反射系で収差図に何も表示されない

放物面等を含む反射系で球面収差図や波面収差図を表示させると収差曲線が現れません。

  →たとえばニュートン系では光軸上は無収差です。収差曲線が 0 の線に重なっているものと思われます。焦点位置を動かしてみて下さい。


OHARA、HOYA、Schottの硝種表がない

OHARA、HOYA及 び Schott の硝種データはウェブ上からダウンロードして下さい。 その上で、データは表計算ソフトを用いて「Ohara.txt」「HOYA.txt」「Schott.txt」の名前でタブ区切り又 はカンマ区切りテキストファイルとしてセーブして下さい。 また Inifile でそれぞれのデータファイル名を上記と違う名前に指定している場合には、そのファイルを用意して下さい。 Ohara.txt 及び HOYA.txt 等これらのファイルは本ソフトLensCal.exe と同一フォルダ上にないと認識されません。


波動光学的像面図を選んでも何も表示されない

上のタブで波動光学的像面を選んで「OK」を押した場合には、計算は行われず何も表示されません。これは、FFT の計算や表示に時間がかかるので、焦点位置や計算波長等を変更したい場合などにいちいち待たされるのを避けるためです。
上のメニューの「計算」－「実行」を選択するか、計算機アイコンを押して下さい。

なお、格子模様のアイコンを押して出る「入射瞳分割数」ダイヤログで 「Execute」を選んだ場合には直ちに計算・表示が行われます。


波動光学的像面図が出てこない

計算機アイコンを押しても表示されません。画面が固まります。
→ FFTサイズによっては計算に大変時間がかかります。ウィンドウの上のタイトルが「しばらくお待ち下さい」となっていれば計算中です。また、「しばらくお 待ち下さい」が出てくるまでに時間がかかることがあります。


波動光学的像面図で画面の中央しか表示されない

波動光学的像面図では、計算された範囲しか表示されません。
図の拡大率を下げて表示範囲を広げると、画面周囲の計算されていない部分は白く表示されます。先に拡大率を下げ、再計算してみて下さ い。
再計算しても表示範囲が広がらない場合には、入射瞳分割数を大きく取る必要があります。

FFT サイズを大きくとると、計算される範囲が広がりますが、計算には 時間がかかります。


物理メモリ不足

この警告が出たときは、コンピュータの空きメモリの不足のため、ハードディスクへのスワップが起こり、計算時間がかなりかかりま す。この状態での計算実行はおすすめできません。

なお、必要メモリ量の厳密な計算は行っておりませんので、この警告が出なくてもスワップが起きる可能性があります。また、この警告が 出たときには場合によっては論理メモリ不足でプログラムエラーが発生して終了することがあります。
この警告が出た場合には、プログラム終了後に Windows の再起動をお勧めします。

上下ボタンの下側を押してもこの警告が出続けて数値が変わらないことがあります。このような場合には一度、上側のボタンを押してみて 下さい。


論理メモリ不足

コンピュータの論理メモリ不足のため、FFT の計算は実行できません。 このサイズの FFT の計算を行うためには、メモリの増設またはハードディスク空き容量の確保が必要です。 他に起動中のアプリケーションがある場合にはそれを終了してみて下さい。


波動光学的像面図で像面に格子模様が見える

像面に格子模様が見えるのは正常です。FFT の計算結果について内挿を行わずにそのまま表示しているため、計算間隔ごとの模様が現れています。 解像度を上げて模様を細かくするためには、FFT サイズと入射瞳分割数の比を大きくして下さい。


硝種一覧に F や SF がない

各メーカの最近の硝種には鉛ガラスがなくなっています。これらを含む昔のレンズを調べたい場合には、旧バージョンに入っていた 「sumita.txt」などをお使い下さい。
なお、旧版は http://yamachan.la.coocan.jp/yama/File/LensCb**.lzh にありますので、**のところに適当な数字（58など）を入れて下さい。


Helpのバージョン

本 Help は LensCal Version β0.69 用のものです。


本プログラムについて

本プログラムはDelphi 2006で書いてあります。しかし私はDelphiも素人なので、よく解っていません。ソースファイルを検討していただけるような詳しい方、ご連絡下さ い。

本プログラムは将来にわたってフリーソフトです。著作権は放棄していません。


プログラミングについて

  私が初めてプログラム言語に触れたのは34年前で（ほとんどわかっていないFortranは除く）、MZ-Basicでした。そ のすぐ後に使いだしたのがHP-Basicという強力な構造化言語です。QuickBasicは友人のプログラムをきっかけに始めま した。N88-Basicも少しはやらざるを得ませんでした・・・。
  その後、WindowsならDelphiだろうと思ってこれに決めました。（パスカルの壁よりもVisualの壁の方が高いだろ う、どうせなら性能が上の方が、という考えです。）　でも難しいですね、未だに一つのプログラムエラーの原因をつかむのに一日かかり ます。

  レンズ計算プログラムを組もうと思った最大の動機は、住田光学のホタロンの出現でした。知人の作ったこのガラスを用いればきっと良 い光学系ができるだろうと思ったのです。
  初めにレンズ計算プログラムを作ったのは31年ぐらい前でした。写真工業の高野栄一氏のレンズ設計の連載記事が大変刺激になり、友 人の作った光線追跡ルーチンを手本に、HP-Basicを用いて組みました。本プログラムは機能的には当時のそのプログラムとあまり 変わりありません。その後友人がQuickBasicを用いてプログラムを書き、それにHP-BASICで実現していた機能を追加し てさらに改良し、'95年頃まで使っていました。
  Delphiを使いだしたのはバージョン１からですが、当時はポインタの壁が厚く、移植する力がありませんでした。
  Delphiもバージョン４になってから動的配列の使用が可能になり（中身はポインタですが）、ようやく手がでるようになって本プ ログラムを書きました。
  コアの計算式の部分は友人のプログラムそのままです。この部分にバグがあるとしたら、そのせいです（笑）。


わかっている不具合

以下のものは現在判明しているものです。

・球面収差図で、屈折率によってはレンズの端の部分が切れて表示されないことがあります。
・軸はずし光学系では、スポットダイヤグラム、波面収差(面)、波動光学的像面図は表示できますが、それ以外の球面収差図等はまとも に表示されません。
・同様に軸はずし光学系では収差図のベンディングはうまくできません。
・反射鏡の斜鏡径は長軸径を入れ、斜鏡による影は、データ例のように、前方 に別に絞り用の面を挿入して下さい。
・レンズ断面図で、光線が図の上下からはみ出す場合には、はみ出した部分は表示されません。ウィンドウを上下に拡大して下さい。
・焦点が存在しない場合のレンズ断面図では、図のサイズが入れた数値と異なっています。
・ベンディングで、両側が同じ屈折率の面を選択しないで下さい。
・Undo の結果がおかしいことがあります。
・レンズ断面図ウィンドウを開いたままメインメニューで新たなデータをロードしたとき、レンズ断面図がうまく表示されないことがあり ます。一度ウィンドウを閉じて、再度メニューから選択して下さい。
・縦球面収差図等を開いたままデータの最適化を行うと、収差図が横球面収差図に変わってしまいます。
・収差図ウィンドウで背景色を変えている場合に波面収差図（面）を表示させると、背景色が白に戻ってしまいます。
・収差図で、スケールに比べて収差が大変大きいときに、収差曲線が一部正しくない位置に表示され奇妙に折れ曲がる場合があります。
・波動光学的像面図に像強度曲線を表示している場合に、マウスカーソルの移動によって曲線が消えることがあります。とりあえず、現わ れる再描画ボタンを押して下さい。


バグ報告について

たとえばバージョンβ0.36 では、横球面収差図で大きすぎる入射角を入れるとエラーが出る、最適化でレンズ厚がマイナスになる可能性があるなどのバグがありました。

また新バージョンで新たな機能を追加した場合、計算が誤っていたり、機能追加に伴って不具合が生じたりすることがあります。

このようなバグを発見したときには、是非ご報告下さい。連絡先は
yama1@wombat.zaq.ne.jp
です。


制限事項

現在のところ、
・淡色表示が変化しないものにはまだ対応していません。
・cut、copy、paste は可能な場所が限られています。Undo も効かない場合があります。
・次の面までの距離は正の値又は０のみが有効です。光線が逆戻りする仮想的な光学系は計算できません。
・主光線の位置を決める入射瞳位置は近軸上での値をそのまま用いています。
・スポットダイヤグラムの光線間隔は現在格子上の点のみ
・最適化は横球面収差の値を利用して計算しているので、考慮されているのはサジタル面とメリディオナル面のみ
・最適化では現在非球面係数の補正には対応していません。
・メモリリークは未チェック
等となっています。

その他、面数の制限等については確認していません。メモリが許す限り大丈夫なのか、それとも途中でハング・・・・？


免責事項

お約束ですが、本プログラムによるいかなる障害、損害にも責任は持てません。
    予想される損害－－突然ハングアップして同時に動かしていた他のアプリケーションのデータが失われることがある


開発環境等

このプログラムは初めAMD K6-266MHz改＋メモリ128MBマシン上で1280×1024pixel＋24ビットカラー＋大きいフォントのディスプレーを用いて Windows95＋Delphi４で開発しました。
最後は AMD Athlon 64 ＋メモリ1GBマシンでWindowsXp＋Delphi 2006 を用いて修正しました。

現在Windows10での動作を確認していますが、Delphi XE5上ではプログラムの修正がまだできない状態です。


謝辞

本プログラムの作成に当たり、以下の本や雑誌の記事を参考にしました。

・光学セミナー、高野栄一、写真工業　1988年３号～
・レンズデザインプログラム、高野栄一、写真工業出版社、1994年
・レンズ設計光学、中川治平、東海大学出版会、1986年
・科学計測のための波形データ処理、南茂夫編著、ＣＱ出版社
・フーリエ結像論、小瀬輝次、共立出版、1979年（あまりわかってません）
・レンズ設計のための波面光学、草川徹、東海大学出版会、1976年（ほとんど理解できてません）

特に高野氏には以前に、設計したレンズ構成について有用なアドバイスをいただきました。

また本プログラムの光線追跡部分は友人の藤塚氏が組んだものをそのまま移植しております。

レンズデータ例の大部分は、～Ｔｏｍ～さんのＲＡＣＥ Ver0.2 に付属のデータから採りました。

FFTプログラムは、Takuya OOURAさんの汎用FFTパッケージプログラム
Copyright Takuya OOURA, 1996-2001
のCとFortranのソースコードからDelphiに移植したものを用いました。

なお、このヘルプの元は HelpDesigner という Koji27 さんのフリーソフトで作成しました。

皆様に感謝いたします。